aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2019-06-26 14:41:33 +0200
committerMartchus2019-06-26 14:41:33 +0200
commit7e9790ef70cdbf8552595445b938883ba09b475b (patch)
tree54f43d30ddceeb2d28776b5e9966044aab7f7f81 /PKGBUILD
parent748a3f030424dc491a60d5166204dee722f9cbb6 (diff)
downloadaur-7e9790ef70cdbf8552595445b938883ba09b475b.tar.gz
Update to 5.13.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD205
1 files changed, 108 insertions, 97 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 663b51fb4789..a0cb9805719c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
# All patches are managed at https://github.com/Martchus/qtbase
-# Helper functions for the split builds
+# define helper functions for the split builds
isDefault() {
[[ $pkgname = 'mingw-w64-qt5-base' ]] || [[ $pkgname = 'mingw-w64-qt5-base-static' ]]
}
@@ -19,14 +19,10 @@ isStatic() {
[ "${pkgname##*-}" = 'static' ]
}
isOpenGL() {
- # Currently use native OpenGL by default
- isDefault || \
- [[ $pkgname = 'mingw-w64-qt5-base-opengl' ]] || [[ $pkgname = 'mingw-w64-qt5-base-opengl-static' ]]
+ isDefault || [[ $pkgname = 'mingw-w64-qt5-base-opengl' ]] || [[ $pkgname = 'mingw-w64-qt5-base-opengl-static' ]]
}
isANGLE() {
- [[ $pkgname = 'mingw-w64-qt5-base-angle' ]] || [[ $pkgname = 'mingw-w64-qt5-base-angle-static' ]] || \
- [[ $pkgname = 'mingw-w64-qt5-base-dynamic' ]] || [[ $pkgname = 'mingw-w64-qt5-base-dynamic-static' ]]
- # Treat dynamic version like ANGLE version, correct?
+ [[ $pkgname = 'mingw-w64-qt5-base-angle' ]] || [[ $pkgname = 'mingw-w64-qt5-base-angle-static' ]]
}
isDynamic() {
[[ $pkgname = 'mingw-w64-qt5-base-dynamic' ]] || [[ $pkgname = 'mingw-w64-qt5-base-dynamic-static' ]]
@@ -36,7 +32,7 @@ isNoOpenGL() {
}
pkgname=mingw-w64-qt5-base
-pkgver=5.12.3
+pkgver=5.13.0
pkgrel=1
pkgdesc='A cross-platform application and UI framework (mingw-w64)'
# The static variant doesn't contain any executables which need to be executed on the build machine
@@ -47,92 +43,90 @@ depends=('mingw-w64-crt' 'mingw-w64-zlib' 'mingw-w64-libjpeg-turbo' 'mingw-w64-s
'mingw-w64-libpng' 'mingw-w64-openssl' 'mingw-w64-dbus' 'mingw-w64-harfbuzz'
'mingw-w64-pcre2')
groups=('mingw-w64-qt5')
-optdepends=('mingw-w64-postgresql: PostgreSQL support' 'mingw-w64-mariadb-connector-c: MySQL support')
-makedepends=('mingw-w64-gcc' 'mingw-w64-postgresql' 'mingw-w64-mariadb-connector-c' 'mingw-w64-pkg-config')
+optdepends=('mingw-w64-mesa: use LLVMpipe software rasterizer for Qt Quick'
+ 'mingw-w64-postgresql: PostgreSQL support'
+ 'mingw-w64-mariadb-connector-c: MySQL support')
+makedepends=('mingw-w64-gcc' 'mingw-w64-postgresql' 'mingw-w64-mariadb-connector-c'
+ 'mingw-w64-vulkan-headers' 'mingw-w64-pkg-config')
+# For running fxc.exe WINE coulde be used:
+#if isANGLE || isDynamic; then
+# makedepends+=('mingw-w64-wine')
+#fi
options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
_pkgfqn="qtbase-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
'0001-Adjust-win32-g-profile-for-cross-compilation-with-mi.patch'
'0002-Ensure-GLdouble-is-defined-when-using-dynamic-OpenGL.patch'
- '0003-Use-external-ANGLE-library.patch'
- '0004-Fix-too-many-sections-assemler-error-in-OpenGL-facto.patch'
- '0005-Make-sure-.pc-files-are-installed-correctly.patch'
- '0006-Don-t-add-resource-files-to-LIBS-parameter.patch'
- '0007-Prevent-debug-library-names-in-pkg-config-files.patch'
- '0008-Fix-linking-against-shared-static-libpng.patch'
- '0009-Fix-linking-against-static-D-Bus.patch'
- '0010-Don-t-try-to-use-debug-version-of-D-Bus-library.patch'
- '0011-Fix-linking-against-static-freetype2.patch'
- '0012-Fix-linking-against-static-harfbuzz.patch'
- '0013-Fix-linking-against-static-pcre.patch'
- '0014-Fix-linking-against-shared-static-MariaDB.patch'
- '0015-Fix-linking-against-shared-static-PostgreSQL.patch'
- '0016-Rename-qtmain-to-qt5main.patch'
- '0017-Build-dynamic-host-libraries.patch'
- '0018-Enable-rpath-for-build-tools.patch'
- '0019-Use-system-zlib-for-build-tools.patch'
- '0020-Use-.dll.a-as-import-lib-extension.patch'
- '0021-Merge-shared-and-static-library-trees.patch'
- '0022-Pull-dependencies-of-static-libraries-in-CMake-modul.patch'
- '0023-Allow-usage-of-static-version-with-CMake.patch'
- '0024-Adjust-linker-flags-for-static-build-with-cmake-ming.patch'
- '0025-Use-correct-pkg-config-static-flag.patch'
- '0026-Fix-macro-invoking-moc-rcc-and-uic.patch'
- '0027-Ignore-errors-about-missing-feature-static.patch'
- '0028-Enable-and-fix-use-of-iconv.patch'
- '0029-Ignore-failing-pkg-config-test.patch'
- '0030-Prevent-qmake-from-messing-static-lib-dependencies.patch'
- '0031-Hardcode-linker-flags-for-platform-plugins.patch'
- '0032-Fix-linking-against-static-plugins-with-qmake.patch'
- '0033-Disable-hardware-randomizer-for-32-bit.patch'
- '0034-Prevent-static-build-to-prefer-dynamic-libraries.patch')
-sha256sums=('fddfd8852ef7503febeed67b876d1425160869ae2b1ae8e10b3fb0fedc5fe701'
- '813332969dbfd7fcc8af3d23457eea0ce3b3a54ed9b9eae62b431529b8f60b22'
- '96b9e2fb177de9c8cfe8c8cd601705981d4c223eef9fc582ec0f45d26c6b6d7f'
- 'b1aa13e0e6e28718edb11520660954101c662f6b6945a83cb4e84ff7de5c0922'
- '2be87f841ac2104f44114ec65dbd35f8bf8280176b9341015b99aa7dd6756967'
- 'c61a62a241b0d03354b523dd9d4ae811e55b12e6e2683c45a3bfd67574e2ad8a'
- '1050833662659481606f94a2f4a95f764e7d1ae8b9d015a497b508884cd755d0'
- 'eea4870ab1394e9473fe1cee2d856bb5d0d31b68ec91b20d45c882893049a9f6'
- '11a4267ae9fa3d49046945ba7e0867b400364f0475c2d36814af45fbc4c3f2f0'
- '2b977aba78484cb01208300d02a9ce945edfa0ac73ad91c9331cb73851c9b85d'
- 'd9e8736c57f5f8841238fe131508d29d9de0fa3d0c0554e1a443aab33147b430'
- 'f30bd604cf3da044f38da38d873a988870d0413aafa5f437d11286d2d3dbb42b'
- '00b84c1b66212797876b1793b36e3537dc866770f632b4d98b91d84e6766c2d8'
- '2fdf313e492061c7a34b63b25129c253088714a632616437c7ab473b43eca5be'
- '6cde53dd184b5aa79e3c471392eaa6e2ac9dc72e8394dab7248cb8a0ac3e856f'
- '64b37f777b45bc1b134ea5723ccc6c430784ebbf53b428addeb73ba1108c9225'
- '7b4398060dd40fcf8f23b5ca908a0f79be7adfe7f15ad9ec77f23913b5c6c3fc'
- 'bfb28bde40b37d74585174414a647af051a8da251107513d3c5e160c72fa7af5'
- '9809aab5b4fadf65c2704654ac2c171877b634d5b874af6c96574159ba9f2002'
- '374b0ed5fe0285389dda11a6fbccabd3094d2aaa7489d3e59d9b31ead444ce27'
- '0961354456c56fa6041758ee35f26d563e60f4ed3bcae214abec2ffbd89f3e80'
- '78681b7f7a6456cda9ca4bef34bf4caf3dfbeb36e7fc8b12a834b5e4da328926'
- 'a95252d2305437fe5ada214162b9952efbc6f3e97399e55cb003d1c394f1770a'
- 'b7b16afef904785a9681b2c03c98a54e8edb224568c63d155bd3f0f1b0508054'
- 'd883c7c1148e2177c7ff23a3fdbdc3956b9b963c82661f227e2c57829358c7f4'
- '0b90abe95bbe585ba2b39b98b7e3cdb85d6827a2afdb8ed677e6a83e33a31009'
- 'bcbe378ec13c845939cf69899bdeb50a7711eef1e5e5127cdc1c9b020f1edd20'
- 'eaa58ae6a0fa740fbd376a39b1c2fab9d77c3eae1456ecef47caef9cc4587638'
- 'd183ee330c718b440c72ebd90cea389bf13cc99e6a34bf15d4818d663b06ec50'
- '673b15ce54ff120d17e7ddc20bcc8c9467bee16935b7ab1ec45946307c8caf56'
- 'c1d67dfed8e9b43fe0e4ab20c5f9c918c83ecc8ba8930e9cf123beb90d11318b'
- '9df19c8cb6017640944211186ce9a6e21715411e896938de2a6d48368372f23e'
- '043ad519351be44de7d93f775abce8da2880e4eb698ff9444558f4795dab26cc'
- '4180fbc2315ddfc1a7763333c1dc507661bd30689c9162f1e58bf01a6fc9f9f2'
- '0d981d8a25039ff57e5375f34ea036021890fe7302f5f710beb1e5ca1e019e48')
+ '0003-Fix-too-many-sections-assemler-error-in-OpenGL-facto.patch'
+ '0004-Make-sure-.pc-files-are-installed-correctly.patch'
+ '0005-Don-t-add-resource-files-to-LIBS-parameter.patch'
+ '0006-Prevent-debug-library-names-in-pkg-config-files.patch'
+ '0007-Fix-linking-against-shared-static-libpng.patch'
+ '0008-Fix-linking-against-static-D-Bus.patch'
+ '0009-Don-t-try-to-use-debug-version-of-D-Bus-library.patch'
+ '0010-Fix-linking-against-static-freetype2.patch'
+ '0011-Fix-linking-against-static-harfbuzz.patch'
+ '0012-Fix-linking-against-static-pcre.patch'
+ '0013-Fix-linking-against-shared-static-MariaDB.patch'
+ '0014-Fix-linking-against-shared-static-PostgreSQL.patch'
+ '0015-Rename-qtmain-to-qt5main.patch'
+ '0016-Enable-rpath-for-build-tools.patch'
+ '0017-Use-system-zlib-for-build-tools.patch'
+ '0018-Merge-shared-and-static-library-trees.patch'
+ '0019-Use-.dll.a-as-import-lib-extension.patch'
+ '0020-Pull-dependencies-of-static-libraries-in-CMake-modul.patch'
+ '0021-Allow-usage-of-static-version-with-CMake.patch'
+ '0022-Adjust-linker-flags-for-static-build-with-cmake-ming.patch'
+ '0023-Use-correct-pkg-config-static-flag.patch'
+ '0024-Fix-macro-invoking-moc-rcc-and-uic.patch'
+ '0025-Ignore-errors-about-missing-feature-static.patch'
+ '0026-Enable-and-fix-use-of-iconv.patch'
+ '0027-Ignore-failing-pkg-config-test.patch'
+ '0028-Prevent-qmake-from-messing-static-lib-dependencies.patch'
+ '0029-Hardcode-linker-flags-for-platform-plugins.patch'
+ '0030-Fix-linking-against-static-plugins-with-qmake.patch'
+ '0031-Disable-hardware-randomizer-for-32-bit.patch'
+ '0032-Prevent-static-build-to-prefer-dynamic-libraries.patch'
+ '0033-Prevent-Cannot-find-feature-windows_vulkan_sdk.patch')
+sha256sums=('ff6964b3b528cd3b1d21bcf3470006e8e5cbe69591923f982871d886ea0488fe'
+ '2df58c3c5350a7b52ed9a19b23359e8a33644012bd529fd31a42afca08a7de33'
+ '58473061f71f210a8344581cd5654bb6e9625cad90e63cf1f9dca063d14f187b'
+ '161e3e3dec7904a889bfe90bd707c00f8e2f471cde0ba7803ebd7997fc84878c'
+ '11b0bbb41bf8f502932f0d8d79e8470654b6adeaaec63de247d044c695e455b8'
+ '556c1b413d079e6f86974a576f3052645fd5919003fe38056f38a66146cc8c6d'
+ 'f59764fa27a9d17f4651f7745416d30570d68b11813f4bc132506213a859e0c0'
+ 'c9e4f335c8d0cf53f4ecff9b6642d34d4794b9fbd75a2fe7f4219f908e998b43'
+ 'c11a3f2354a8c0b8e12890e09c321ac486c29f32a2702c3d123cd51b49f8152e'
+ 'cdd71e7ea046327502872da3657132f276159f7377626a41b1a592a8aa2a435f'
+ '002780bf246a151763fb970234bffc9bb6f82a5e6b3c99641c455a650fad9cd6'
+ 'e6b535f1959a1cc5b27aefd3b69f05393d0631bd384c946da278e61f1bce6da9'
+ '56b4695cd46189d297f8583f5d130ef2ed2a91f96ccef76d4d70b59a52da1a6e'
+ '1f55fbf4a5d3dfbe7a2a3f282f0e393e8c88a5b982c694cdaf557aa5508d4be8'
+ '39b0c2de05cf7f51a513fe555520d80cc8a22119c4e3b245459ee486f88d902b'
+ '9a0714b960e82e723828bd18c0bd3a722f58eacb058960aed2e9fcbe4b8d2537'
+ '94dc91c13b5876d05348717b94f0bee6eca3470852e4b0a99f3d5768ee09ec6c'
+ '6129e5bb57e18ab064fbc9c15b7708368bc93e65b0c16ec1c83708f01e2862f1'
+ 'ae3cc5e48f69bcb065d919ea1ff6cd4e8216cff348348675dc0932887e62d2c8'
+ '1bf5cbfeab7139e1af66909e9359ed051b02d335cd032e1d87539f7a46974c09'
+ 'e8bceae99d8b6a802592fb7476ac68f2f015cbca0dc38959076c5029f63d0f23'
+ 'b491f47044b2ea161ec9881d7211ededfd1b3481f54ca93381498a50aebd3795'
+ '3dbb78c2ec5d3b2f33d5545de15da2ee2895978e98d35a677eaa1449e592cf3c'
+ '99782fd0b3cb20f2ce5425607f5f6b909ecaefcd8e038738c19d76ae3dc43ab6'
+ '0ce174399229425fc1f9fac6e27dc9fc7b04dd4eb4770f471fb62244368e6e64'
+ '365459aba005e00fb19cf0fbeb42f563d36b0b7ac9737ea981f4f4034af6e229'
+ '486c27a6a56140f6f43665b79b960dafb93d1d48a2d4b5a0de330f3e55685cf8'
+ '3f4dbd1417a63d04e5e938a37b5a614940d19c318aeeb2de43c126804a509053'
+ 'ca721a40d0be358baa31233b0d9db8ee70483dc25dda96dbdb080158e90200fb'
+ '2ba848d3a4e2a3230ee70473fdd7adb6aadb021fea2f09b7871033f281425855'
+ '6cff295c7011ce53319f35749d807cc6b0c3596ae92d9c36e0eb2cecbafd182e'
+ '45aae3d21e88cc0ac9e008cd0cc98e3178c2319d0aef726677555866c3bd4b59'
+ '6d661273b5f6c61c02dd0a0d3b4e7c5788646b056ba7aa3cbad125c84199ffc5'
+ '7e42f2b917e18dfc22e9f4fb7d7d5c1717157e9746fdaf25b55217b0b78d87be')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
isStatic && depends+=(${pkgname%-static})
-if isANGLE; then
- if isDynamic; then
- makedepends+=('mingw-w64-angleproject')
- optdepends+=('mingw-w64-angleproject: use ANGLE instead of native OpenGL')
- else
- depends+=('mingw-w64-angleproject')
- fi
-fi
+
if ! isDefault; then
if isStatic; then
provides+=('mingw-w64-qt5-base-static')
@@ -155,9 +149,9 @@ prepare() {
done
# make sure the Qt 5 build system uses our external ANGLE library
- rm -rf src/3rdparty/angle include/QtANGLE/{EGL,GLES2,GLES3,KHR}
+ #rm -rf src/3rdparty/angle include/QtANGLE/{EGL,GLES2,GLES3,KHR}
- # as well as our external PCRE library and zlib
+ # make sure the Qt 5 build system uses our external PCRE library and zlib
rm -rf src/3rdparty/{pcre,zlib}
# build qmake using mingw-w64 {C,LD}FLAGS
@@ -252,20 +246,30 @@ build() {
msg2 'Building without OpenGL support'
qt_configure_args+=' -no-opengl'
elif isANGLE; then
- if isDynamic; then
- msg2 'Using dynamic OpenGL backend'
- qt_configure_args+=' -opengl dynamic'
- else
- msg2 'Using ANGLE as OpenGL backend'
- qt_configure_args+=' -angle'
- fi
+ # FIXME: This is broken because we needed to invoke fxc.exe (Direct3D Shader Compiler)
+ # during the build. Maybe start it with WINE?
+ msg2 'Using ANGLE as OpenGL backend'
+ qt_configure_args+=' -angle'
# enable declarations of GLES functions
+ # FIXME: Still required?
+ qt_configure_args+=' -DGL_GLEXT_PROTOTYPES'
+ elif isDynamic; then
+ # FIXME: This is broken because is requires enabling the (bundled) ANGLE which is
+ # broken (see comment under isANGLE).
+ msg2 'Using dynamic OpenGL backend'
+ qt_configure_args+=' -opengl dynamic'
+ qt_configure_args+=' -angle'
+ # enable declarations of GLES functions
+ # FIXME: Still required?
qt_configure_args+=' -DGL_GLEXT_PROTOTYPES'
fi
# add include directory of MariaDB
qt_configure_args+=" -I/usr/${_arch}/include/mariadb"
+ # add include directory for Vulkan
+ export VULKAN_SDK=/usr/${_arch}
+
msg2 'Configure and build qmake'
mkdir -p ../build-${_arch} && pushd ../build-${_arch}
if isStatic; then
@@ -284,8 +288,8 @@ build() {
qt_configure_args+=' -device-option CROSS_COMPILE_CUSTOM_CONFIG=actually_a_shared_build'
# override LD_LIBRARY_PATH so libraries for native build tools like libQt5Bootstrap.so are found
- export LD_LIBRARY_PATH="$PWD/lib"
- export LDFLAGS="-L$PWD/lib"
+ #export LD_LIBRARY_PATH="$PWD/lib"
+ #export LDFLAGS="-L$PWD/lib"
fi
msg2 'Build qmake and configure' && ../${_pkgfqn}/configure $qt_configure_args
@@ -327,6 +331,7 @@ package() {
"${pkgdir}/usr/${_arch}/lib/"{lib,}Qt5OpenGLExtensions* \
"${pkgdir}/usr/${_arch}/lib/"{lib,}Qt5PlatformSupport* \
"${pkgdir}/usr/${_arch}/lib/"{lib,}Qt5WindowsUIAutomationSupport* \
+ "${pkgdir}/usr/${_arch}/lib/"{lib,}Qt5VulkanSupport* \
"${pkgdir}/usr/${_arch}/lib/"libQt5Bootstrap* \
# ensure config files don't conflict with shared version
@@ -344,6 +349,7 @@ package() {
pushd "${pkgdir}/usr/${_arch}/lib/" && ln -s "./qt/plugins/"*/*.a . && popd
# keep a couple pri files not found in base
+ mv "${pkgdir}/usr/${_arch}/lib/qt/mkspecs/qdevice.static.pri" "${pkgdir}/usr/${_arch}"
mv "${pkgdir}/usr/${_arch}/lib/qt/mkspecs/modules/qt_plugin_"*.pri "${pkgdir}/usr/${_arch}"
# fix bad library order for static CMake builds caused by Qt5Gui.static.prl
@@ -357,12 +363,16 @@ package() {
# move pri files back
mkdir -p "${pkgdir}/usr/${_arch}/lib/qt/mkspecs/modules"
+ mv "${pkgdir}/usr/${_arch}/qdevice.static.pri" "${pkgdir}/usr/${_arch}/lib/qt/mkspecs"
mv "${pkgdir}/usr/${_arch}/"*.pri "${pkgdir}/usr/${_arch}/lib/qt/mkspecs/modules"
else # shared version
# remove DLLs from libdir (DLLs are installed in both bindir and libdir, one copy is sufficient)
find "${pkgdir}/usr/${_arch}/lib" -maxdepth 1 -name "*.dll" -exec rm {} \;
+ # install missing libQt5BootstrapDBus.a manually
+ cp --target-directory "${pkgdir}/usr/${_arch}/lib" "$srcdir/build-${_arch}/lib/libQt5BootstrapDBus.a"
+
# create symlinks for tools
mkdir -p "${pkgdir}/usr/bin"
for tool in qmake moc rcc uic qdbuscpp2xml qdbusxml2cpp qdoc syncqt.pl; do
@@ -389,7 +399,8 @@ package() {
# strip binaries, remove unuseful files
if ! isStatic; then
strip --strip-all "${pkgdir}/usr/${_arch}/lib/qt/bin/"*[!.pl]
- strip --strip-unneeded "${pkgdir}/usr/${_arch}/lib/libQt5Bootstrap"{,DBus}.so.${pkgver}
+ strip --strip-debug "${pkgdir}/usr/${_arch}/lib/libQt5Bootstrap"*.a
+ #strip --strip-unneeded "${pkgdir}/usr/${_arch}/lib/libQt5Bootstrap"{,DBus}.so.${pkgver}
fi
if isStatic || [[ $NO_EXECUTABLES ]]; then
find "${pkgdir}/usr/${_arch}" -name '*.exe' -delete