aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2016-03-28 19:52:10 +0200
committerMartchus2016-03-28 19:52:10 +0200
commitdabae9421ba89f01d529aa1d7f53836ac72377fb (patch)
tree04788b794209b76214f10500e33f8eca1c010694 /PKGBUILD
parent3564bd5b15c3cd1825795965e2f17a52a227d60e (diff)
downloadaur-dabae9421ba89f01d529aa1d7f53836ac72377fb.tar.gz
updated to 5.6.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD69
1 files changed, 25 insertions, 44 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c8809529613a..abdace4a6486 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,12 @@
# Contributor: Filip Brcic <brcha@gna.org>
# Contributor: jellysheep <max.mail@dameweb.de>
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
pkgname=mingw-w64-qt5-base
-pkgver=5.5.1
-pkgrel=2
+pkgver=5.6.0
+pkgrel=1
pkgdesc="A cross-platform application and UI framework (mingw-w64)"
arch=(i686 x86_64)
url="https://www.qt.io/"
@@ -36,7 +39,6 @@ makedepends=(mingw-w64-gcc
options=(!strip !buildflags staticlibs)
_pkgfqn="qtbase-opensource-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
- "qt5-merge-static-and-shared-library-trees.patch"
"add-angle-support.patch"
"use-external-angle-library.patch"
"qt5-workaround-pkgconfig-install-issue.patch"
@@ -46,37 +48,32 @@ source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/sub
"qt5-enable-rpath-for-host-tools.patch"
"qt5-dont-add-resource-files-to-qmake-libs.patch"
"qt5-prevent-debug-library-names-in-pkgconfig-files.patch"
- "qt5-qmake-implib-dll-a.patch"
"qt5-fix-static-dbus-detection.patch"
- "qt5-fix-static-harfbuzz-detection.patch"
"qt5-use-win32-g++-mkspecs-profile.patch"
"qt5-use-system-zlib-in-host-libs.patch"
"fix-opengl-to-many-sections.patch"
"fix-static-psql-mysql.patch"
- "qt5-disable-angle-opengl-testcode.patch"
"qt5-fix-QSemaphore-problem.patch"
- "a91c40868bbdc1b2d2dd3b5f8b47aae9e8589a81.diff")
-md5sums=('687e2b122fa2c3390b5e20a166d38038'
- 'f51eb2b176b10af943831d33925c1251'
+ "qtbase-1-fixes.patch"
+ "qt5-fix-implib-ext.patch")
+md5sums=('d6b6cfd333c22829c6c85fc52ceed019'
'bab00ccc19d888997f323c80354a7c3f'
- 'ec25d1ff4033383cd5d2414d8189c228'
+ '9916ded318f21afbe8388f0b9822062b'
'bc99c4cc6998295d76f37ed681c20d47'
'4fe6523dd1c34398df3aa5a8763530cc'
- 'c4d4ca54a2e9096d2af13a266177f6d6'
+ '22be0aa7fc36c5d08b3b41f0eccf7479'
'3bd322551924543553a2bf81b4419a09'
- '15e8eaa4f0a9a9990277c79e243770be'
+ '30fa9ddf8d842b1392e8d63868940657'
'99bb9f51ec684803768f36e407baf486'
'6a6bc88f35ac8080869de39bc128ce5b'
- 'e793479e0b86b39ddafd328140f1a24c'
'40de3aaf7d713034e06f4eece665b1ba'
- '4149c27286f110e37893d1764d4c8a68'
- '39cdea1b39a1d993df6d01a576e8116f'
+ 'd0c7198115ff028188ed1759b70fd981'
'a265dea62755caf38187114143999224'
'612a4dfb9f1a3898a1920c28bb999159'
'd0eb81aef1a21c65813fe4ddabbc4206'
- '0076233a43e7edaaaf8c2abca2ada8df'
'87cbd116c75ced1b075bf266f2455d50'
- '1bc70e7e3ea6a0178891d984f0451b3c')
+ '62d2977e57fccf1f16d7ea6bf06d3279'
+ '207420d43e997d1d41ef9684ef7fb715')
_architectures="x86_64-w64-mingw32 i686-w64-mingw32"
# Helper functions for the split builds
@@ -96,11 +93,8 @@ isOpenGL && conflicts+=("mingw-w64-qt5-base")
prepare() {
cd "${srcdir}/${_pkgfqn}"
- # When building Qt as static library some files have a different content
- # when compared to the static library. Merge those changes manually.
- # This patch also applies some additional changes which are required to make
- # linking against the static version of Qt work without any manual fiddling
- patch -p0 -i ../qt5-merge-static-and-shared-library-trees.patch
+ # include fixes from MXE
+ patch -p1 -b -i ../qtbase-1-fixes.patch
if ! isOpenGL; then
# Add support for Angle
@@ -130,12 +124,8 @@ prepare() {
# files for the debug build an unique file name
patch -p1 -i ../qt5-prevent-debug-library-names-in-pkgconfig-files.patch
- # Fix qmake to create implibs with .dll.a extension for MinGW
- patch -p1 -i ../qt5-qmake-implib-dll-a.patch
-
- # As of Qt 5.4.1 the detection of the static DBus and Harfbuzz libraries got broken
+ # Fix the detection of the static DBus
patch -p1 -i ../qt5-fix-static-dbus-detection.patch
- patch -p1 -i ../qt5-fix-static-harfbuzz-detection.patch
# Patch the win32-g++ mkspecs profile to match our environment
patch -p1 -i ../qt5-use-win32-g++-mkspecs-profile.patch
@@ -168,26 +158,16 @@ prepare() {
# Build host libs with system zlib. This patch cannot be upstreamed as-is
# due to the other host-libs patches.
patch -p1 -i ../qt5-use-system-zlib-in-host-libs.patch
-
- # Workaround a compatibility issue because we are using an older version of ANGLE in Fedora
- # Upgrading the mingw-angleproject package isn't possible for now because mingw-qt5-qtwebkit doesn't support the latest ANGLE yet..
- #
- # /home/erik/fedora/mingw-qt5-qtbase/qtbase-opensource-src-5.5.0/src/plugins/platforms/windows/qwindowseglcontext.cpp:376:15: error: 'EGL_PLATFORM_ANGLE_DEVICE_TYPE_ANGLE' was not declared in this scope
- # EGL_PLATFORM_ANGLE_DEVICE_TYPE_ANGLE, EGL_PLATFORM_ANGLE_DEVICE_TYPE_WARP_ANGLE, EGL_NONE }
- # ^
- # /home/erik/fedora/mingw-qt5-qtbase/qtbase-opensource-src-5.5.0/src/plugins/platforms/windows/qwindowseglcontext.cpp:376:53: error: 'EGL_PLATFORM_ANGLE_DEVICE_TYPE_WARP_ANGLE' was not declared in this scope
- # EGL_PLATFORM_ANGLE_DEVICE_TYPE_ANGLE, EGL_PLATFORM_ANGLE_DEVICE_TYPE_WARP_ANGLE, EGL_NONE }
- patch -p1 -b -i ../qt5-disable-angle-opengl-testcode.patch
- patch configure ../qt5-fix-QSemaphore-problem.patch
+ # Fix qmake to append .dll.a extension to import libs
+ patch -p1 -i ../qt5-fix-implib-ext.patch
- # QTBUG-49174 Prevent warning output when QWebView loads QNetworkRequest
- patch -p1 -b -i ../a91c40868bbdc1b2d2dd3b5f8b47aae9e8589a81.diff
+ patch configure ../qt5-fix-QSemaphore-problem.patch
isStatic && patch -p0 -i ../fix-static-psql-mysql.patch
# Make sure the Qt5 build system uses our external ANGLE library
- rm -rf src/3rdparty/angle include/QtANGLE/{EGL,GLES2,KHR}
+ rm -rf src/3rdparty/angle include/QtANGLE/{EGL,GLES2,GLES3,KHR}
# As well as our external PCRE library and zlib
rm -rf src/3rdparty/{pcre,zlib}
@@ -248,7 +228,7 @@ build() {
-sysconfdir /usr/${_arch}/etc \
-translationdir /usr/${_arch}/share/qt/translations \
-device-option CROSS_COMPILE=${_arch}-"
-
+
# fix include directory of dbus
qt_configure_args+=" $(${_arch}-pkg-config --cflags-only-I dbus-1 --cflags)"
@@ -350,11 +330,12 @@ package() {
# remove doc
rm -rf "${pkgdir}/usr/${_arch}/share/doc"
- # And finaly, strip the binaries
+ # strip the binaries
if ! isStatic; then
+ strip --strip-all "${pkgdir}/usr/${_arch}/lib/qt/bin/"*[!.pl]
strip --strip-unneeded "${pkgdir}/usr/${_arch}/lib/libQt5Bootstrap"{,DBus}.so.${pkgver}
fi
-
+
# keeping prl files for base build since qbs seems to need them.
if isStatic; then
rm -f "${pkgdir}/usr/${_arch}/lib"{,/qt/plugins/*}/*.prl