summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilip A Reimer2015-09-12 13:01:05 -0600
committerPhilip A Reimer2015-09-12 13:01:05 -0600
commitab6d11a580513ec4bd335151e680fb8e2f807e93 (patch)
tree04244649379f764418739127315b14a594d4c43d /PKGBUILD
parente04961421583a194000a162822534faa2a66cb0c (diff)
downloadaur-ab6d11a580513ec4bd335151e680fb8e2f807e93.tar.gz
Update to 5.5.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD111
1 files changed, 49 insertions, 62 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dc4564a51142..0b23ac33e9b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Filip Brcic <brcha@gna.org>
# Contributor: jellysheep <max.mail@dameweb.de>
pkgname=mingw-w64-qt5-base-opengl
-pkgver=5.4.2
+pkgver=5.5.0
pkgrel=1
pkgdesc="A cross-platform application and UI framework (mingw-w64)"
arch=(i686 x86_64)
@@ -33,17 +33,15 @@ makedepends=(mingw-w64-gcc
mingw-w64-pkg-config)
options=(!strip !buildflags staticlibs)
_pkgfqn="qtbase-opensource-src-${pkgver}"
-source=("http://download.qt-project.org/official_releases/qt/5.4/${pkgver}/submodules/${_pkgfqn}.tar.xz"
+source=("http://download.qt-project.org/official_releases/qt/5.5/${pkgver}/submodules/${_pkgfqn}.tar.xz"
"qt5-merge-static-and-shared-library-trees.patch"
- "qt5-add-angle-support.patch"
- "angle-fix.patch"
- "qt5-use-external-angle-library.patch"
+ "add-angle-support.patch"
+ "use-external-angle-library.patch"
"qt5-workaround-pkgconfig-install-issue.patch"
"qt5-qtbase-fix-linking-against-static-pcre.patch"
"qt5-rename-qtmain-to-qt5main.patch"
"qt5-dont-build-host-libs-static.patch"
"qt5-enable-rpath-for-host-tools.patch"
- "qt5-add-compiled-shaders-remove-dxsdk.patch"
"qt5-dont-add-resource-files-to-qmake-libs.patch"
"qt5-prevent-debug-library-names-in-pkgconfig-files.patch"
"qt5-qmake-implib-dll-a.patch"
@@ -51,30 +49,28 @@ source=("http://download.qt-project.org/official_releases/qt/5.4/${pkgver}/submo
"qt5-fix-static-harfbuzz-detection.patch"
"qt5-use-win32-g++-mkspecs-profile.patch"
"qt5-use-system-zlib-in-host-libs.patch"
- "qt-5.1.x-win_flex-replace.patch"
"fix-opengl-to-many-sections.patch"
- "fix-static-psql-mysql.patch")
-md5sums=('67a95eec79ffc4a14f516ad6f3d24c96'
+ "fix-static-psql-mysql.patch"
+ "qt5-disable-angle-opengl-testcode.patch")
+md5sums=('252613b5a180c94d7196d10467a4f08b'
'f51eb2b176b10af943831d33925c1251'
- '8c6bda3ce8aca368b1f50f57e5f25aa7'
- 'af4ac76fb9d1ea383359ea881ffcd8e3'
- '361e456685180a4004de6af76c58ddba'
- '19debeaea610e70691fae3b2a0a94eaa'
+ 'bab00ccc19d888997f323c80354a7c3f'
+ 'ec25d1ff4033383cd5d2414d8189c228'
+ 'bc99c4cc6998295d76f37ed681c20d47'
'4fe6523dd1c34398df3aa5a8763530cc'
'c4d4ca54a2e9096d2af13a266177f6d6'
'3bd322551924543553a2bf81b4419a09'
'15e8eaa4f0a9a9990277c79e243770be'
- 'bd0ced78eafaf187197d64f9e381c6c5'
- '47b2aa0c6251c24c3c36c86b86a99c4c'
+ '99bb9f51ec684803768f36e407baf486'
'6a6bc88f35ac8080869de39bc128ce5b'
- '474de0e31122ecd140ebc19fe3960057'
+ 'e793479e0b86b39ddafd328140f1a24c'
'40de3aaf7d713034e06f4eece665b1ba'
'1a7921cadeb5c3db383dea068519e8d3'
- 'f0e068b82ca41ae32c0d72587f070dd8'
+ '6aea7182982098de045721f51bf20fc2'
'a265dea62755caf38187114143999224'
- '852519f457e33e0d1e9d2a2df872967d'
'612a4dfb9f1a3898a1920c28bb999159'
- 'd0eb81aef1a21c65813fe4ddabbc4206')
+ 'd0eb81aef1a21c65813fe4ddabbc4206'
+ '0076233a43e7edaaaf8c2abca2ada8df')
_architectures="x86_64-w64-mingw32 i686-w64-mingw32"
# Helper functions for the split builds
@@ -86,15 +82,10 @@ isOpenGL() {
[ $pkgname = "mingw-w64-qt5-base-opengl" ]
}
-isInternalAngle() {
- [ $pkgname = "mingw-w64-qt5-base-internal-angle" ]
-}
-
isStatic && depends+=("mingw-w64-qt5-base")
-! isOpenGL && ! isInternalAngle && depends+=("mingw-w64-angleproject")
-isOpenGL || isInternalAngle && provides+=("mingw-w64-qt5-base")
-isOpenGL || isInternalAngle && conflicts+=("mingw-w64-qt5-base")
-isInternalAngle && conflicts+=("mingw-w64-angleproject")
+! isOpenGL && depends+=("mingw-w64-angleproject")
+isOpenGL && provides+=("mingw-w64-qt5-base")
+isOpenGL && conflicts+=("mingw-w64-qt5-base")
prepare() {
cd "${srcdir}/${_pkgfqn}"
@@ -103,28 +94,26 @@ prepare() {
# when compared to the static library. Merge those changes manually.
# This patch also applies some additional changes which are required to make
# linking against the static version of Qt work without any manual fiddling
- patch -p0 -i "${srcdir}/qt5-merge-static-and-shared-library-trees.patch"
+ patch -p0 -i ../qt5-merge-static-and-shared-library-trees.patch
if ! isOpenGL; then
# Add support for Angle
- patch -p0 -i "${srcdir}/qt5-add-angle-support.patch"
- fi
+ patch -p1 -i ../add-angle-support.patch
- if ! isOpenGL && ! isInternalAngle; then
# Make sure our external Angle package is used instead of the bundled one
- patch -p0 -i "${srcdir}/qt5-use-external-angle-library.patch"
+ patch -p1 -i ../use-external-angle-library.patch
fi
-
+
# opengl to many sections error
isOpenGL && patch -p0 -i ../fix-opengl-to-many-sections.patch
# Make sure the .pc files of the Qt5 modules are installed correctly
- patch -p0 -i "${srcdir}/qt5-workaround-pkgconfig-install-issue.patch"
+ patch -p0 -i ../qt5-workaround-pkgconfig-install-issue.patch
# Prevents resource files from being added to the LIBS parameter
# This solves an issue where the generated pkg-config files contained
# invalid Libs.private references like .obj/debug/Qt5Cored_resource_res.o
- patch -p1 -i "${srcdir}/qt5-dont-add-resource-files-to-qmake-libs.patch"
+ patch -p1 -i ../qt5-dont-add-resource-files-to-qmake-libs.patch
# qmake generates the pkgconfig .pc files two times, once for the
# release build and once for the debug build (which we're not actually
@@ -133,34 +122,34 @@ prepare() {
# build ending up in the .pc files which are unwanted
# Prevent this from happening by giving the pkgconfig .pc
# files for the debug build an unique file name
- patch -p1 -i "${srcdir}/qt5-prevent-debug-library-names-in-pkgconfig-files.patch"
+ patch -p1 -i ../qt5-prevent-debug-library-names-in-pkgconfig-files.patch
# Fix qmake to create implibs with .dll.a extension for MinGW
- patch -p1 -i "${srcdir}/qt5-qmake-implib-dll-a.patch"
+ patch -p1 -i ../qt5-qmake-implib-dll-a.patch
# As of Qt 5.4.1 the detection of the static DBus and Harfbuzz libraries got broken
patch -p1 -i ../qt5-fix-static-dbus-detection.patch
patch -p1 -i ../qt5-fix-static-harfbuzz-detection.patch
# Patch the win32-g++ mkspecs profile to match our environment
- patch -p0 -i "${srcdir}/qt5-use-win32-g++-mkspecs-profile.patch"
+ patch -p1 -i ../qt5-use-win32-g++-mkspecs-profile.patch
# The bundled pcre is built as static library by default
# As we're not using the bundled copy but our own copy
# we need to do some fiddling to fix compilation issues
# when trying to build static qmake projects
- patch -p1 -i "${srcdir}/qt5-qtbase-fix-linking-against-static-pcre.patch"
+ patch -p1 -i ../qt5-qtbase-fix-linking-against-static-pcre.patch
# Make sure the qtmain (static) library doesn't conflict with the one
# provided by the mingw-qt (qt4) package. The mkspecs profile is already
# updated by patch100 to reflect this change
# https://bugzilla.redhat.com/show_bug.cgi?id=1092465
- patch -p1 -i "${srcdir}/qt5-rename-qtmain-to-qt5main.patch"
+ patch -p1 -i ../qt5-rename-qtmain-to-qt5main.patch
# Upstream always wants the host libraries to be static instead of
# shared libraries. This causes issues and is against the Fedora
# packaging guidelines so disable this 'feature'
- patch -p0 -i "${srcdir}/qt5-dont-build-host-libs-static.patch"
+ patch -p0 -i ../qt5-dont-build-host-libs-static.patch
# Build host tools with rpath enabled
# We have to use rpath here as the library which the
@@ -168,34 +157,29 @@ prepare() {
# in the folder /usr/${_arch}/lib
# We can't use the regular %%_libdir for this as we
# want to avoid conflicts with the native qt5 packages
- patch -p1 -i "${srcdir}/qt5-enable-rpath-for-host-tools.patch"
+ patch -p1 -i ../qt5-enable-rpath-for-host-tools.patch
# Build host libs with system zlib. This patch cannot be upstreamed as-is
# due to the other host-libs patches.
- patch -p1 -i "${srcdir}/qt5-use-system-zlib-in-host-libs.patch"
+ patch -p1 -i ../qt5-use-system-zlib-in-host-libs.patch
+
+ # Workaround a compatibility issue because we are using an older version of ANGLE in Fedora
+ # Upgrading the mingw-angleproject package isn't possible for now because mingw-qt5-qtwebkit doesn't support the latest ANGLE yet..
+ #
+ # /home/erik/fedora/mingw-qt5-qtbase/qtbase-opensource-src-5.5.0/src/plugins/platforms/windows/qwindowseglcontext.cpp:376:15: error: 'EGL_PLATFORM_ANGLE_DEVICE_TYPE_ANGLE' was not declared in this scope
+ # EGL_PLATFORM_ANGLE_DEVICE_TYPE_ANGLE, EGL_PLATFORM_ANGLE_DEVICE_TYPE_WARP_ANGLE, EGL_NONE }
+ # ^
+ # /home/erik/fedora/mingw-qt5-qtbase/qtbase-opensource-src-5.5.0/src/plugins/platforms/windows/qwindowseglcontext.cpp:376:53: error: 'EGL_PLATFORM_ANGLE_DEVICE_TYPE_WARP_ANGLE' was not declared in this scope
+ # EGL_PLATFORM_ANGLE_DEVICE_TYPE_ANGLE, EGL_PLATFORM_ANGLE_DEVICE_TYPE_WARP_ANGLE, EGL_NONE }
+ patch -p1 -b -i ../qt5-disable-angle-opengl-testcode.patch
- if ! isInternalAngle; then
- # Make sure the Qt5 build system uses our external ANGLE library
- rm -rf src/3rdparty/angle include/QtANGLE/{EGL,GLES2,KHR}
- fi
+ isStatic && patch -p0 -i ../fix-static-psql-mysql.patch
+
+ # Make sure the Qt5 build system uses our external ANGLE library
+ rm -rf src/3rdparty/angle include/QtANGLE/{EGL,GLES2,KHR}
# As well as our external PCRE library and zlib
rm -rf src/3rdparty/{pcre,zlib}
-
- if isStatic; then
- patch -p0 -i ../fix-static-psql-mysql.patch
- fi
-
- if isInternalAngle; then
- # fix make[6]: win_flex: Command not found
- patch -p2 -i "${srcdir}/qt-5.1.x-win_flex-replace.patch"
- # Fix Angle. See https://code.google.com/p/angleproject/issues/detail?id=462
- patch -p0 -i "${srcdir}/angle-fix.patch"
- patch -p0 < "${srcdir}/qt5-add-compiled-shaders-remove-dxsdk.patch"
- find ./src/3rdparty/angle -type f -and \( -name *.h -or -name *.cpp \) | xargs sed -i \
- -e 's_#include <D3Dcompiler.h>_#include <d3dcompiler.h>_' \
- -e 's_#include "libGLESv2/Constants.h"_#include "libGLESv2/constants.h"_'
- fi
}
build() {
@@ -252,6 +236,9 @@ build() {
-sysconfdir /usr/${_arch}/etc \
-translationdir /usr/${_arch}/share/qt/translations \
-device-option CROSS_COMPILE=${_arch}-"
+
+ # fix include directory of dbus
+ qt_configure_args+=" $(${_arch}-pkg-config --cflags-only-I dbus-1 --cflags)"
isOpenGL && qt_configure_args+=' -opengl desktop'
isStatic && qt_configure_args+=' -opengl no'