summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilip A Reimer2015-06-14 12:26:34 -0600
committerPhilip A Reimer2015-06-14 12:26:34 -0600
commite04961421583a194000a162822534faa2a66cb0c (patch)
tree7943ddca09cc41776ce8b2c2550a82fc1be80793 /PKGBUILD
parent45974ade4482f67dadd8c0afa516ddfd18cfb052 (diff)
downloadaur-e04961421583a194000a162822534faa2a66cb0c.tar.gz
update to 5.4.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 26 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eb03f043dd20..dc4564a51142 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Filip Brcic <brcha@gna.org>
# Contributor: jellysheep <max.mail@dameweb.de>
pkgname=mingw-w64-qt5-base-opengl
-pkgver=5.4.1
+pkgver=5.4.2
pkgrel=1
pkgdesc="A cross-platform application and UI framework (mingw-w64)"
arch=(i686 x86_64)
@@ -19,6 +19,7 @@ depends=(
mingw-w64-libdbus
mingw-w64-pcre
mingw-w64-harfbuzz
+ mingw-w64-glib2
)
groups=(mingw-w64-qt mingw-w64-qt5)
optdepends=(
@@ -46,11 +47,14 @@ source=("http://download.qt-project.org/official_releases/qt/5.4/${pkgver}/submo
"qt5-dont-add-resource-files-to-qmake-libs.patch"
"qt5-prevent-debug-library-names-in-pkgconfig-files.patch"
"qt5-qmake-implib-dll-a.patch"
+ "qt5-fix-static-dbus-detection.patch"
+ "qt5-fix-static-harfbuzz-detection.patch"
"qt5-use-win32-g++-mkspecs-profile.patch"
"qt5-use-system-zlib-in-host-libs.patch"
"qt-5.1.x-win_flex-replace.patch"
- "fix-opengl-to-many-sections.patch")
-md5sums=('9507825e558c980fed602de1f16ec7ae'
+ "fix-opengl-to-many-sections.patch"
+ "fix-static-psql-mysql.patch")
+md5sums=('67a95eec79ffc4a14f516ad6f3d24c96'
'f51eb2b176b10af943831d33925c1251'
'8c6bda3ce8aca368b1f50f57e5f25aa7'
'af4ac76fb9d1ea383359ea881ffcd8e3'
@@ -64,10 +68,13 @@ md5sums=('9507825e558c980fed602de1f16ec7ae'
'47b2aa0c6251c24c3c36c86b86a99c4c'
'6a6bc88f35ac8080869de39bc128ce5b'
'474de0e31122ecd140ebc19fe3960057'
+ '40de3aaf7d713034e06f4eece665b1ba'
+ '1a7921cadeb5c3db383dea068519e8d3'
'f0e068b82ca41ae32c0d72587f070dd8'
'a265dea62755caf38187114143999224'
'852519f457e33e0d1e9d2a2df872967d'
- '612a4dfb9f1a3898a1920c28bb999159')
+ '612a4dfb9f1a3898a1920c28bb999159'
+ 'd0eb81aef1a21c65813fe4ddabbc4206')
_architectures="x86_64-w64-mingw32 i686-w64-mingw32"
# Helper functions for the split builds
@@ -131,6 +138,10 @@ prepare() {
# Fix qmake to create implibs with .dll.a extension for MinGW
patch -p1 -i "${srcdir}/qt5-qmake-implib-dll-a.patch"
+ # As of Qt 5.4.1 the detection of the static DBus and Harfbuzz libraries got broken
+ patch -p1 -i ../qt5-fix-static-dbus-detection.patch
+ patch -p1 -i ../qt5-fix-static-harfbuzz-detection.patch
+
# Patch the win32-g++ mkspecs profile to match our environment
patch -p0 -i "${srcdir}/qt5-use-win32-g++-mkspecs-profile.patch"
@@ -171,6 +182,10 @@ prepare() {
# As well as our external PCRE library and zlib
rm -rf src/3rdparty/{pcre,zlib}
+ if isStatic; then
+ patch -p0 -i ../fix-static-psql-mysql.patch
+ fi
+
if isInternalAngle; then
# fix make[6]: win_flex: Command not found
patch -p2 -i "${srcdir}/qt-5.1.x-win_flex-replace.patch"
@@ -243,10 +258,11 @@ build() {
unset PKG_CONFIG_PATH
+ if ! isStatic; then
+ export QT_LFLAGS_MYSQL="-L/usr/${_arch}/lib -lmysql"
+ fi
# Qt doesn't detect mysql correctly, so use this:
- # -lz -lws2_32 -ladvapi32 -lkernel32 /usr/i686-w64-mingw32/bin/ssleay32.dll /usr/i686-w64-mingw32/bin/libeay32.dll -lkernel32 -luser32 -lgdi32 -lwinspool -lshell32 -lole32 -loleaut32 -luuid -lcomdlg32 -ladvapi32
export QT_CFLAGS_MYSQL="-I/usr/${_arch}/include/mariadb"
- export QT_LFLAGS_MYSQL="-L/usr/${_arch}/lib -lmysql"
#export QT_LFLAGS_MYSQL_R="-lmariadbclient -lws2_32 -lpthread -lz -lm -lssl -lcrypto"
# Hardcode MySQL flags into configure (really nice solution :( )
sed -e "s|^QT_CFLAGS_MYSQL=.*$|QT_CFLAGS_MYSQL=\"${QT_CFLAGS_MYSQL}\"|g" -i "${srcdir}/${_pkgfqn}/configure"
@@ -328,7 +344,10 @@ package() {
strip --strip-unneeded "${pkgdir}/usr/${_arch}/lib/libQt5Bootstrap"{,DBus}.so.${pkgver}
fi
- # keeping prl files since qbs seems to need them.
+ # keeping prl files for base build since qbs seems to need them.
+ if isStatic; then
+ rm -f "${pkgdir}/usr/${_arch}/lib"{,/qt/plugins/*}/*.prl
+ fi
find "${pkgdir}/usr/${_arch}" -name "*.exe" -o -name "*.bat" -o -name "*.def" -o -name "*.exp" | xargs -rtl1 rm
find "${pkgdir}/usr/${_arch}" -name "*.dll" -exec ${_arch}-strip --strip-unneeded {} \;
find "${pkgdir}/usr/${_arch}" -name "*.a" -o -name "*.dll" | xargs -rtl1 ${_arch}-strip -g