summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2024-03-16 19:43:14 +0100
committerMartchus2024-03-16 19:43:14 +0100
commitc743b463ca8e77ee274e89523697caa51ca052ca (patch)
tree6bd4d97fa8daf12335d2aacaf3d06a105d8a335c /PKGBUILD
parentec6d3a395f87de8b14c56277a31b35d34791e0f0 (diff)
downloadaur-c743b463ca8e77ee274e89523697caa51ca052ca.tar.gz
Update to 5.15.13
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b53dfb278817..ce8e035ca3bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_qt_module=qtdatavis3d
pkgname=mingw-w64-qt5-datavis3d-static
-pkgver=5.15.12
+pkgver=5.15.13
pkgrel=1
arch=('any')
pkgdesc="Qt Data Visualization module (mingw-w64)"
@@ -17,7 +17,7 @@ depends=('mingw-w64-qt5-base-static')
optdepends=('mingw-w64-qt5-declarative-static: QML bindings')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-qt5-declarative-static')
license=('GPL3' 'LGPL' 'FDL' 'custom')
-_commit=c887477198cae44585fe9db371db0ddf4c3b205e
+_commit=6ac6d23a8f558f36f1162b419858cc44dccd4d2b
_basever=${pkgver%%+*}
makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
@@ -25,7 +25,7 @@ groups=('mingw-w64-qt5')
url='https://www.qt.io/'
_pkgfqn=${_qt_module}
source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
-sha256sums=('SKIP')
+sha256sums=('649c0c535c76f781aeda6a7a262904c71dd438e4a4762dd2e507f696544c8c35')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
@@ -49,7 +49,7 @@ build() {
msg2 "Building ${_config##*=} version for ${_arch}"
mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
- make
+ make -j$(nproc)
popd
done
done
@@ -62,7 +62,7 @@ package() {
for _config in "${_configurations[@]}"; do
pushd build-${_arch}-${_config##*=}
- make INSTALL_ROOT="$pkgdir" install
+ make -j$(nproc) INSTALL_ROOT="$pkgdir" install
# use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
if [[ -d 'lib' ]]; then