summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2020-09-13 13:26:32 +0200
committerMartchus2020-09-13 13:26:32 +0200
commit021ee348702beeaa39ed59376c68cca9c06a36a8 (patch)
tree8aeff7599524c7d405aab69675036ae459fc3afe /PKGBUILD
parent515b191afcf24f4ab46362128ab4deafaa38df42 (diff)
downloadaur-021ee348702beeaa39ed59376c68cca9c06a36a8.tar.gz
Update to 5.15.1
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD20
1 files changed, 6 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd835d6733fd..6cca876249eb 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,18 +6,15 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
-# This file is created from PKGBUILD.sh.in contained by the mentioned repository.
+# This file is created from PKGBUILD.sh.ep contained by the mentioned repository.
# Do not edit it manually! See README.md in the repository's root directory
# for more information.
# All patches are managed at https://github.com/Martchus/qtdeclarative
-# Includes dynamic and static versions; if only one version is requried, just
-# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
-
_qt_module=qtdeclarative
pkgname=mingw-w64-qt5-declarative
-pkgver=5.15.0
+pkgver=5.15.1
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='Classes for QML and JavaScript languages (mingw-w64)'
@@ -31,18 +28,13 @@ _pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
'0001-Ensure-static-plugins-are-exported.patch'
'0002-Prevent-exporting-QML-parser-symbols-on-static-build.patch')
-sha256sums=('9c3c93fb7d340b2f7d738d12408c047318c78973cb45bfc5ff6b3a57e1fef699'
- '4af477df8c06dfd9fd5a8a34ec5b79e175e87187a040d7081bd5eaa809c7d81d'
- 'f3463ab91e8b6b12b4dd210ae012203ef83f90a2ce59a2f324daf0a98ed3f0b5')
+sha256sums=('7e30f0ccba61f9d71720b91d7f7523c23677f23cd96065cb71df1b0df329d768'
+ 'accdeab4cb49857442f680a6013a648108ec4f00078e492475794aa6cc98257e'
+ '7ff5093753aa819c6039de796e6ebffa235b51f57403e827b31a90e8c2ffbf60')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
-[[ $NO_STATIC_LIBS ]] || \
- makedepends+=('mingw-w64-qt5-base-static') \
- optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
- _configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
-[[ $NO_SHARED_LIBS ]] || \
- _configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
+_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
prepare() {
cd "${srcdir}/${_pkgfqn}"