summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2020-09-13 13:26:33 +0200
committerMartchus2020-09-13 13:26:33 +0200
commit206e82118dbcd29fbb67263d61b650111624ddb3 (patch)
tree44fcbe87df556fcfa54867d164adf91f9f993315 /PKGBUILD
downloadaur-206e82118dbcd29fbb67263d61b650111624ddb3.tar.gz
Update to 5.15.1
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD123
1 files changed, 123 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..101cccab330c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,123 @@
+# Maintainer: Martchus <martchus@gmx.net>
+# Contributor: ant32 <antreimer@gmail.com>
+# Contributor: Filip Brcic <brcha@gna.org>
+# Contributor: ohmyarch
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+# This file is created from PKGBUILD.sh.ep contained by the mentioned repository.
+# Do not edit it manually! See README.md in the repository's root directory
+# for more information.
+
+# All patches are managed at https://github.com/Martchus/qtdeclarative
+
+_qt_module=qtdeclarative
+pkgname=mingw-w64-qt5-declarative-static
+pkgver=5.15.1
+pkgrel=1
+arch=('any')
+pkgdesc='Classes for QML and JavaScript languages (mingw-w64)'
+depends=('mingw-w64-qt5-base-static')
+makedepends=('mingw-w64-gcc' 'mingw-w64-vulkan-headers' 'mingw-w64-pkg-config' 'python')
+license=('GPL3' 'LGPL3' 'FDL' 'custom')
+options=('!strip' '!buildflags' 'staticlibs')
+groups=('mingw-w64-qt5')
+url='https://www.qt.io/'
+_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
+ '0001-Ensure-static-plugins-are-exported.patch'
+ '0002-Prevent-exporting-QML-parser-symbols-on-static-build.patch')
+sha256sums=('7e30f0ccba61f9d71720b91d7f7523c23677f23cd96065cb71df1b0df329d768'
+ 'accdeab4cb49857442f680a6013a648108ec4f00078e492475794aa6cc98257e'
+ '7ff5093753aa819c6039de796e6ebffa235b51f57403e827b31a90e8c2ffbf60')
+
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+
+depends+=(${pkgname%-static}) # the static version relies on the shared version for build tools and headers
+_configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
+
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ # apply patches; further descriptions can be found in patch files itself
+ for patch in "$srcdir/"*.patch; do
+ patch -p1 -i "$patch"
+ done
+}
+
+build() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ for _config in "${_configurations[@]}"; do
+ msg2 "Building ${_config##*=} version for ${_arch}"
+ mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
+ make
+ popd
+ done
+ done
+}
+
+package() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ for _config in "${_configurations[@]}"; do
+ pushd build-${_arch}-${_config##*=}
+
+ make INSTALL_ROOT="$pkgdir" install
+
+ # use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
+ if [[ -d 'lib' ]]; then
+ pushd 'lib'
+ find -iname '*.static.prl' -exec cp --target-directory "${pkgdir}/usr/${_arch}/lib" --parents {} +
+ popd
+ fi
+ if [[ -d 'plugins' ]]; then
+ pushd 'plugins'
+ find -iname '*.static.prl' -exec cp --target-directory "${pkgdir}/usr/${_arch}/lib/qt/plugins" --parents {} +
+ popd
+ fi
+
+ # replace library path in *.prl files so it points to the installed location and not the build directory
+ find "${pkgdir}/usr/${_arch}/lib" \( -type f -name '*.prl' -o -name '*.pc' \) -exec sed -i -e "s:$PWD/lib:/usr/$_arch/lib:g" {} \;
+
+ # remove prl files for debug version
+ if ! [[ $MINGW_W64_QT_DEBUG_BUILD ]]; then
+ for file in $(find "${pkgdir}/usr/${_arch}" -name '*d.prl' -o -name '*d.static.prl'); do
+ [ -f "${file%d*}${file##*d}" ] && rm "${file}";
+ done
+ fi
+
+ # remove '.static.prl' files
+ find "${pkgdir}/usr/${_arch}" -name '.static.prl' -delete
+
+ # delete duplicate files that are in the shared package
+ find "${pkgdir}/usr/${_arch}" -name '*.exe' -delete
+ for shared_path in "${pkgdir}/usr/${_arch}/"{include,share} "${pkgdir}/usr/${_arch}/lib/"{qt/bin,qt/mkspecs}; do
+ [[ -d $shared_path ]] && rm -fR "$shared_path"
+ done
+ for file in $(find "$pkgdir/usr/$_arch/lib"); do
+ [[ -f "${file##$pkgdir}" ]] && rm "$file"
+ done
+
+ find "${pkgdir}/usr/${_arch}/lib" -maxdepth 1 -name '*.dll' -delete
+ find "${pkgdir}/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "${pkgdir}/usr/${_arch}" \( -name '*.a' -not -name 'libQt5QmlDevTools.a' -not -name 'libQt5Bootstrap.a' \) -exec ${_arch}-strip -g {} \;
+ [[ -d "${pkgdir}/usr/${_arch}/lib/qt/bin/" ]] && \
+ find "${pkgdir}/usr/${_arch}/lib/qt/bin/" -exec strip --strip-all {} \;
+ find "${pkgdir}/usr/${_arch}/lib/" -iname "*.so.$pkgver" -exec strip --strip-unneeded {} \;
+ popd
+ done
+
+ # strip native static libraries
+ find "${pkgdir}/usr/${_arch}" -name 'libQt5QmlDevTools.a' -exec strip -g {} \;
+
+ # drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/${_arch}/lib" -type f -name '*.prl' -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+ done
+
+}
+