summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2020-01-29 19:09:36 +0100
committerMartchus2020-01-29 19:09:36 +0100
commit6b19ef82fdfbb7284dddc21e5614f6c54ba0b8ee (patch)
tree1c9323e21a3729d0561560aea65c606c5e4de030 /PKGBUILD
parent47817bc42ed39276c7c3b416159d1ab5d07947d7 (diff)
downloadaur-6b19ef82fdfbb7284dddc21e5614f6c54ba0b8ee.tar.gz
Update to 5.14.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ace18c54a7fe..a6fa2aa43d73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,16 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
+# This file is created from PKGBUILD.sh.in contained by the mentioned repository.
+# Do not edit it manually! See README.md in the repository's root directory
+# for more information.
+
# Includes dynamic and static versions; if only one version is requried, just
# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
_qt_module=qtimageformats
-pkgname="mingw-w64-qt5-imageformats"
-pkgver=5.14.0
+pkgname=mingw-w64-qt5-imageformats
+pkgver=5.14.1
pkgrel=1
arch=('any')
pkgdesc="Plugins for additional image formats: TIFF, MNG, TGA, WBMP (mingw-w64)"
@@ -20,19 +24,20 @@ depends=('mingw-w64-qt5-base')
#depends+=('mingw-w64-libmng') # for MNG
#depends+=('mingw-w64-libwebp') # for WebP
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
+license=('GPL3' 'LGPL' 'FDL' 'custom')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
-license=('GPL3' 'LGPL' 'FDL' 'custom')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('959f169af5fc09ef248062a457b78a667acafee71e57ea14fb14ff6f5dd898d5')
+sha256sums=('b8b177ea68df3a99f45740cb3193e3b38738c5e2b272028445bd31a4305c8e5e')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+
[[ $NO_STATIC_LIBS ]] || \
makedepends+=('mingw-w64-qt5-base-static') \
optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
- _configurations+=('CONFIG+=static')
+ _configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
[[ $NO_SHARED_LIBS ]] || \
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
@@ -43,7 +48,7 @@ build() {
for _config in "${_configurations[@]}"; do
msg2 "Building ${_config##*=} version for ${_arch}"
mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
- ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config}
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
make
popd
done