summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2022-03-08 23:35:32 +0100
committerMartchus2022-03-08 23:35:32 +0100
commit6d027c3ab081084450cb76cdf81f1cb5ad4c853d (patch)
tree8fe861e2dfc9f5ccf9375e372a63c3956fb07e31 /PKGBUILD
parentebe17531f8d118f0871212ea455cd214707fdd73 (diff)
downloadaur-6d027c3ab081084450cb76cdf81f1cb5ad4c853d.tar.gz
Rebase against 5.15.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 17 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4aa28c48df59..b9d77ee7c96b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
_qt_module=qtnetworkauth
pkgname=mingw-w64-qt5-networkauth
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('any')
pkgdesc="Network authentication module (mingw-w64)"
@@ -18,17 +18,30 @@ depends=('mingw-w64-qt5-base')
optdepends=()
makedepends=('mingw-w64-gcc')
license=('GPL3' 'LGPL3' 'FDL' 'custom')
+_commit=958db00a2064f77b354b573102ca2c2b2e07529c
+_basever=$pkgver
+pkgver+=+kde+r0
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('fcc2ec42faa68561efa8f00cd72e662fbc06563ebc6de1dc42d96bb2997acd85')
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
+sha256sums=('SKIP')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
+pkgver() {
+ cd $_pkgfqn
+ echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+}
+
build() {
cd "${srcdir}/${_pkgfqn}"