summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2022-03-08 23:35:31 +0100
committerMartchus2022-03-08 23:35:31 +0100
commit4272b81bbe72c5e0d3e9f6eec030c894db1b65f6 (patch)
tree9637e3779e03283d10976c8952b3b2f7e22eda26 /PKGBUILD
parentf9ea98e5f34cab156df5d357f6d6c3fd7cf09346 (diff)
downloadaur-4272b81bbe72c5e0d3e9f6eec030c894db1b65f6.tar.gz
Rebase against 5.15.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 20 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 14f52a5b48cc..167daacde95f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_qt_module=qtremoteobjects
pkgname=mingw-w64-qt5-remoteobjects
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Inter-process communication (IPC) module developed for Qt (mingw-w64)"
@@ -17,17 +17,30 @@ depends=('mingw-w64-qt5-base')
optdepends=('mingw-w64-qt5-declarative: QML bindings')
makedepends=('mingw-w64-gcc' 'mingw-w64-qt5-declarative')
license=('GPL3' 'LGPL' 'FDL' 'custom')
+_commit=581475dfeb44c8b51c0be86e0f2f57df7d117a80
+_basever=$pkgver
+pkgver+=+kde+r0
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('6781b6bc90888254ea77ce812736dac00c67fa4eeb3095f5cd65e4b9c15dcfc2')
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
+sha256sums=('SKIP')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
+pkgver() {
+ cd $_pkgfqn
+ echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+}
+
build() {
cd "${srcdir}/${_pkgfqn}"
@@ -45,6 +58,9 @@ build() {
find . -type f -iname 'Makefile' -exec sed -i "s|-L/usr/$_arch/lib -lQt5Bootstrap|-L/usr/lib /usr/$_arch/lib/libQt5Bootstrap.so|g" {} \;
find . -type f -iname 'Makefile' -exec sed -i "s|-lQt5Bootstrap ||g" {} \;
+ # avoid `.obj/release/qconnectionfactories.o:qconnectionfactories.cpp:(.text.unlikely+0xf): relocation truncated to fit: IMAGE_REL_AMD64_REL32 against undefined symbol `__cxa_pure_virtual'`
+ [[ $_arch == x86_64-w64-mingw32 ]] && find . -type f -iname 'Makefile*' -exec sed -i 's|\(CXX.*\)\( -o .obj/release/qconnectionfactories.o\)|\1 -mcmodel=large \2|g' {} \;
+
make
popd
done