summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2019-09-09 20:29:27 +0200
committerMartchus2019-09-09 20:29:27 +0200
commit8f8c57f072674ac34922bcbe57def344d3ff8f98 (patch)
tree1d803bbe9e3241f7b2a0c7359f7bc46327b4ef8f /PKGBUILD
parentb3925b48bbc17614568adc818a6cdaf154c17c9d (diff)
downloadaur-8f8c57f072674ac34922bcbe57def344d3ff8f98.tar.gz
Update to 5.13.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8779019cbbad..2f9c735393f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
_qt_module=qtremoteobjects
pkgname="mingw-w64-qt5-remoteobjects"
-pkgver=5.13.0
+pkgver=5.13.1
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Inter-process communication (IPC) module developed for Qt (mingw-w64)"
@@ -21,7 +21,7 @@ license=('GPL3' 'LGPL' 'FDL' 'custom')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('24b2fc953ab4db7f46d8b7da38fef2483b2e9a51ea6836007077947e246fdadc')
+sha256sums=('892a10502b2659e6a0f20167a5b6d71338fd01082e33e4b07eba43b0bbfcce69')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_STATIC_LIBS ]] || \
@@ -85,6 +85,9 @@ package() {
done
fi
+ # remove '.static.prl' files
+ find "${pkgdir}/usr/${_arch}" -name '.static.prl' -delete
+
find "${pkgdir}/usr/${_arch}/lib" -maxdepth 1 -name '*.dll' -delete
[ "$NO_STATIC_EXECUTABLES" -a "${_config##*=}" = static -o "$NO_EXECUTABLES" ] && \
find "${pkgdir}/usr/${_arch}" -name '*.exe' -delete || \