summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2020-09-13 13:53:35 +0200
committerMartchus2020-09-13 13:53:35 +0200
commitc731545b44cc0404017f1fe0792d43302cfc24d4 (patch)
tree562ab39f99c44ad721f0d026aacdb3c0fda83b41 /PKGBUILD
parentb7746958f31d39d8d7e41f74f1e448cd02387d76 (diff)
downloadaur-c731545b44cc0404017f1fe0792d43302cfc24d4.tar.gz
Update to 5.15.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 4 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f2ef444e30f2..4bc3da30f69e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,13 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
-# This file is created from PKGBUILD.sh.in contained by the mentioned repository.
+# This file is created from PKGBUILD.sh.ep contained by the mentioned repository.
# Do not edit it manually! See README.md in the repository's root directory
# for more information.
-# Includes dynamic and static versions; if only one version is requried, just
-# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
-
_qt_module=qtremoteobjects
pkgname=mingw-w64-qt5-remoteobjects
-pkgver=5.15.0
+pkgver=5.15.1
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Inter-process communication (IPC) module developed for Qt (mingw-w64)"
@@ -25,16 +22,11 @@ groups=('mingw-w64-qt5')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('86fcfdce77f13c7babdec4dc1d0c4b7b6b02e40120a4250dc59e911c53c08abf')
+sha256sums=('71b58fdac717645fa6f8b6ecb79b86841c540838877d100fabe2381175c4154e')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
-[[ $NO_STATIC_LIBS ]] || \
- makedepends+=('mingw-w64-qt5-base-static') \
- optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
- _configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
-[[ $NO_SHARED_LIBS ]] || \
- _configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
+_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
build() {
cd "${srcdir}/${_pkgfqn}"