summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2022-03-08 23:35:19 +0100
committerMartchus2022-03-08 23:35:19 +0100
commit40904b8dd399240ccd1d3d913432778df7053a3c (patch)
tree24e0d6f51d9d0eb10a3dcb3999b7ddbe4fff5742 /PKGBUILD
parent411ae2941e18606c21381a65c0c492125722b9f2 (diff)
downloadaur-40904b8dd399240ccd1d3d913432778df7053a3c.tar.gz
Rebase against 5.15.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 006dc8a09214..e9fd537dc04d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,24 +10,33 @@
_qt_module=qtserialport
pkgname=mingw-w64-qt5-serialport
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('any')
pkgdesc="Provides access to hardware and virtual serial ports (mingw-w64)"
depends=('mingw-w64-qt5-base')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
license=('GPL3' 'LGPL3' 'FDL' 'custom')
+_commit=f95e2411d7c978def87846ea7cedf3dc5fd7c8b8
+_basever=$pkgver
+pkgver+=+kde+r0
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('59c559d748417306bc1b2cf2315c1e63eed011ace38ad92946af71f23e2ef79d')
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
+sha256sums=('SKIP')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
+pkgver() {
+ cd $_pkgfqn
+ echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
+}
+
prepare() {
cd "${srcdir}/${_pkgfqn}"