summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2024-05-29 00:06:08 +0200
committerMartchus2024-05-29 00:06:08 +0200
commit69215394bbaee8fe084b51af76cbd6d91c825a3c (patch)
treebe30429fc65c37a36540074db52881d2c3b4f8d1 /PKGBUILD
parent2be46993442393b569bcebe16fd543b292593d6c (diff)
downloadaur-69215394bbaee8fe084b51af76cbd6d91c825a3c.tar.gz
Update to 5.15.14
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d8b0f69688f4..2fa8ebfb6936 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,14 +10,14 @@
_qt_module=qtserialport
pkgname=mingw-w64-qt5-serialport
-pkgver=5.15.13
+pkgver=5.15.14
pkgrel=1
arch=('any')
pkgdesc="Provides access to hardware and virtual serial ports (mingw-w64)"
depends=('mingw-w64-qt5-base')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
license=('GPL3' 'LGPL3' 'FDL' 'custom')
-_commit=fc0b6affe244e40366bd624d6e01c62712568eb8
+_commit=34c19c6441cd440dc65b59ae7670eadf099d51f8
_basever=${pkgver%%+*}
makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
@@ -25,7 +25,7 @@ groups=('mingw-w64-qt5')
url='https://www.qt.io/'
_pkgfqn=${_qt_module}
source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
-sha256sums=('41b87d6c4bd1975ee707a19c209310d8233db43232a1ade9cd4e360bf7a861ad')
+sha256sums=('590de1ddfdd1f34cdc0a51169542a2b498c067153697a9fcf3b5f718a510ab4d')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
@@ -51,7 +51,7 @@ build() {
msg2 "Building ${_config##*=} version for ${_arch}"
mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
- make -j$(nproc)
+ make
popd
done
done
@@ -64,7 +64,7 @@ package() {
for _config in "${_configurations[@]}"; do
pushd build-${_arch}-${_config##*=}
- make -j$(nproc) INSTALL_ROOT="$pkgdir" install
+ make INSTALL_ROOT="$pkgdir" install
# use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
if [[ -d 'lib' ]]; then