summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2022-03-08 23:35:15 +0100
committerMartchus2022-03-08 23:35:15 +0100
commit53fc87f8d907240736e51283d7e5a2789423cd78 (patch)
tree0d02e903aff1e69936daaa43390bf4a38748a175 /PKGBUILD
parent7cceb43edf8302b2a72f7fe3fd02cbadd3ea7904 (diff)
downloadaur-53fc87f8d907240736e51283d7e5a2789423cd78.tar.gz
Rebase against 5.15.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 17 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0d5aab50b480..8b43872f141f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,24 +11,37 @@
_qt_module=qttranslations
pkgname=mingw-w64-qt5-translations
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('any')
pkgdesc="A cross-platform application and UI framework (translations, mingw-w64)"
depends=('mingw-w64-qt5-base')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-qt5-tools')
license=('GPL3' 'LGPL3' 'FDL' 'custom')
+_commit=a6d5e7f84a57394db4c8b069f81c56cfeb802e19
+_basever=$pkgver
+pkgver+=+kde+r2
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('d5788e86257b21d5323f1efd94376a213e091d1e5e03b45a95dd052b5f570db8')
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
+sha256sums=('SKIP')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
+pkgver() {
+ cd $_pkgfqn
+ echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+}
+
build() {
cd "${srcdir}/${_pkgfqn}"