diff options
author | Martchus | 2016-08-19 22:10:38 +0200 |
---|---|---|
committer | Martchus | 2016-08-19 22:10:38 +0200 |
commit | 0ba136f15a6e89593c9a8b69306df7cad458dc79 (patch) | |
tree | f894c81e7afe1f6d149d725ed479e4eef2d3f8e7 /PKGBUILD | |
parent | b68c4e594cc64bc69b13ed8b7671ade6d5faa783 (diff) | |
download | aur-0ba136f15a6e89593c9a8b69306df7cad458dc79.tar.gz |
Add static version of further Qt modules
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 48 |
1 files changed, 34 insertions, 14 deletions
@@ -5,10 +5,13 @@ # All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where # you also find the URL of a binary repository. +# Includes dynamic and static versions; if only one version is requried, just +# set $NO_STATIC_LIBS or $NO_SHARED_LIBS. + _qt_module=qtvirtualkeyboard pkgname="mingw-w64-qt5-virtualkeyboard" pkgver=5.7.0 -pkgrel=1 +pkgrel=2 arch=('any') pkgdesc="Virtual keyboard framework (translations, mingw-w64)" depends=('mingw-w64-qt5-declarative' 'mingw-w64-qt5-svg') @@ -20,19 +23,25 @@ _pkgfqn="${_qt_module}-opensource-src-${pkgver}" source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz") md5sums=('fa473ab9175483dd82aa4d27b9682715') -_architectures="i686-w64-mingw32 x86_64-w64-mingw32" +_architectures='i686-w64-mingw32 x86_64-w64-mingw32' +[[ $NO_STATIC_LIBS ]] || \ + makedepends+=('mingw-w64-qt5-base-static') \ + optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \ + _configurations+=('CONFIG+=static') +[[ $NO_SHARED_LIBS ]] || \ + _configurations+=('CONFIG+=shared') -build() -{ +build() { cd "${srcdir}/${_pkgfqn}" for _arch in ${_architectures}; do - mkdir -p build-${_arch} && pushd build-${_arch} - - ${_arch}-qmake-qt5 ../${_qt_module}.pro - make - - popd + for _config in "${_configurations[@]}"; do + msg2 "Building ${_config##*=} version for ${_arch}" + mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=} + ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} + make + popd + done done } @@ -40,9 +49,20 @@ package() { cd "${srcdir}/${_pkgfqn}" for _arch in ${_architectures}; do - pushd build-${_arch} - make INSTALL_ROOT="${pkgdir}" install - find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \; - popd + for _config in "${_configurations[@]}"; do + pushd build-${_arch}-${_config##*=} + + make INSTALL_ROOT="$pkgdir" install + find "${pkgdir}/usr/${_arch}/lib" -maxdepth 1 -name "*.dll" -exec rm {} \; + [ "$NO_STATIC_EXECUTABLES" -a "${_config##*=}" = static -o "$NO_EXECUTABLES" ] && \ + find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec rm {} \; || \ + find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec ${_arch}-strip --strip-all {} \; + find "${pkgdir}/usr/${_arch}" -name "*.dll" -exec ${_arch}-strip --strip-unneeded {} \; + find "${pkgdir}/usr/${_arch}" -name "*.a" -exec ${_arch}-strip -g {} \; + [[ -d "${pkgdir}/usr/${_arch}/lib/qt/bin/" ]] && \ + find "${pkgdir}/usr/${_arch}/lib/qt/bin/" -exec strip --strip-all {} \; + find "${pkgdir}/usr/${_arch}/lib/" -iname "*.so.$pkgver" -exec strip --strip-unneeded {} \; + popd + done done } |