summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2024-03-16 19:42:54 +0100
committerMartchus2024-03-16 19:42:54 +0100
commitf795d970de9d8d2c3e59440ce7626e5c34606a45 (patch)
tree57d6d40b341380acd01661e5d16f66005a41cfbd /PKGBUILD
parent7139c14444efa6986c6fc818d5d06754c81e8188 (diff)
downloadaur-mingw-w64-qt5-websockets.tar.gz
Update to 5.15.13
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a65d165b885e..437f009f385e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,14 +10,14 @@
_qt_module=qtwebsockets
pkgname=mingw-w64-qt5-websockets
-pkgver=5.15.12
+pkgver=5.15.13
pkgrel=1
arch=('any')
pkgdesc="Provides WebSocket communication compliant with RFC 6455 (mingw-w64)"
depends=('mingw-w64-qt5-base')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
license=('GPL3' 'LGPL' 'FDL' 'custom')
-_commit=9a7b9972a54137d5f2e0d49559fe58d07c90662e
+_commit=2c2b7691ae231f43129d7f2b43984c30883ca4b1
_basever=${pkgver%%+*}
pkgver+=+kde+r2
makedepends+=('git')
@@ -26,7 +26,7 @@ groups=('mingw-w64-qt5')
url='https://www.qt.io/'
_pkgfqn=${_qt_module}
source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
-sha256sums=('SKIP')
+sha256sums=('1d94d0f25f4d663fb7dfa80c2c1444b1bc871bdbf00ca18cdc381460cc8f9023')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
@@ -49,7 +49,7 @@ build() {
msg2 "Building ${_config##*=} version for ${_arch}"
mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
- make
+ make -j$(nproc)
popd
done
done
@@ -62,7 +62,7 @@ package() {
for _config in "${_configurations[@]}"; do
pushd build-${_arch}-${_config##*=}
- make INSTALL_ROOT="$pkgdir" install
+ make -j$(nproc) INSTALL_ROOT="$pkgdir" install
# use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
if [[ -d 'lib' ]]; then