summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2024-03-16 19:42:56 +0100
committerMartchus2024-03-16 19:42:56 +0100
commit56ae8000fdbbae1e2e6a913eae5832caf9cbb4c6 (patch)
tree11088f50d562cfe19ddb3cd53c295d313a47c65b /PKGBUILD
parentec8e1bbb09738143ef3b5592d3479b149086f189 (diff)
downloadaur-56ae8000fdbbae1e2e6a913eae5832caf9cbb4c6.tar.gz
Update to 5.15.13
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4dbd56f0585a..b23441d0d601 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,14 +10,14 @@
_qt_module=qtwinextras
pkgname=mingw-w64-qt5-winextras
-pkgver=5.15.12
+pkgver=5.15.13
pkgrel=1
arch=('any')
pkgdesc="Classes and functions that enable you to use Windows-specific functions (mingw-w64)"
depends=('mingw-w64-qt5-base' 'mingw-w64-qt5-declarative')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
license=('GPL3' 'LGPL3' 'LGPL2.1' 'FDL' 'custom')
-_commit=ee931eba5d129284d5c33157cd7d0b9232fbee7b
+_commit=e6a85ae3306867400b8700600152949656eb21f7
_basever=${pkgver%%+*}
makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
@@ -25,7 +25,7 @@ groups=('mingw-w64-qt5')
url='https://www.qt.io/'
_pkgfqn=${_qt_module}
source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
-sha256sums=('SKIP')
+sha256sums=('a489c58f1620d0cabc7c47343119a6881af9f47a832a3e98389952c3366cc29a')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
@@ -48,7 +48,7 @@ build() {
msg2 "Building ${_config##*=} version for ${_arch}"
mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
- make
+ make -j$(nproc)
popd
done
done
@@ -61,7 +61,7 @@ package() {
for _config in "${_configurations[@]}"; do
pushd build-${_arch}-${_config##*=}
- make INSTALL_ROOT="$pkgdir" install
+ make -j$(nproc) INSTALL_ROOT="$pkgdir" install
# use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
if [[ -d 'lib' ]]; then