summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2022-03-08 23:35:18 +0100
committerMartchus2022-03-08 23:35:18 +0100
commitd56dc9cbcca1003c498b5c9e31e2f7c3de2a1596 (patch)
tree67c3e812a9b179fef522d6185460ef4049cca828 /PKGBUILD
parent6e6f5bc502b32f19f6a0d768221874d29e87e466 (diff)
downloadaur-d56dc9cbcca1003c498b5c9e31e2f7c3de2a1596.tar.gz
Rebase against 5.15.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 17 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2267bda93478..ae8dad631cae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,24 +10,37 @@
_qt_module=qtwinextras
pkgname=mingw-w64-qt5-winextras
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('any')
pkgdesc="Classes and functions that enable you to use Windows-specific functions (mingw-w64)"
depends=('mingw-w64-qt5-base' 'mingw-w64-qt5-declarative')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
license=('GPL3' 'LGPL3' 'LGPL2.1' 'FDL' 'custom')
+_commit=051202df9c553d7c0a384f07bd67fde98f3b02c4
+_basever=$pkgver
+pkgver+=+kde+r0
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('65b8272005dec00791ab7d81ab266d1e3313a3bbd8e54e546d984cf4c4ab550e')
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
+sha256sums=('SKIP')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
+pkgver() {
+ cd $_pkgfqn
+ echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+}
+
build() {
cd "${srcdir}/${_pkgfqn}"