summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2020-09-13 13:26:58 +0200
committerMartchus2020-09-13 13:26:58 +0200
commiteb8a0a0ceab144ece19bd36fb2044722f7334a68 (patch)
treef7ca1961b4f231bd5d2595b3a62422765bd0ed6b /PKGBUILD
parent6c7712c7936b8d01003aeb14100164a06ec3d78b (diff)
downloadaur-eb8a0a0ceab144ece19bd36fb2044722f7334a68.tar.gz
Update to 5.15.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 4 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 924e571d9dd4..9416bb54a596 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,13 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
-# This file is created from PKGBUILD.sh.in contained by the mentioned repository.
+# This file is created from PKGBUILD.sh.ep contained by the mentioned repository.
# Do not edit it manually! See README.md in the repository's root directory
# for more information.
-# Includes dynamic and static versions; if only one version is requried, just
-# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
-
_qt_module=qtwinextras
pkgname=mingw-w64-qt5-winextras
-pkgver=5.15.0
+pkgver=5.15.1
pkgrel=1
arch=('any')
pkgdesc="Classes and functions that enable you to use Windows-specific functions (mingw-w64)"
@@ -25,16 +22,11 @@ groups=('mingw-w64-qt5')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('d77f2cb2ce83bdbfd0a970bc8d7d11c96b2df16befc257d6594f79dfd92abff0')
+sha256sums=('c378b112de1b54dbd39b07b7e181250b99ea2ec4d1d710909bb3384665528e8b')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
-[[ $NO_STATIC_LIBS ]] || \
- makedepends+=('mingw-w64-qt5-base-static') \
- optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
- _configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
-[[ $NO_SHARED_LIBS ]] || \
- _configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
+_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
build() {
cd "${srcdir}/${_pkgfqn}"