summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2023-07-20 23:11:51 +0200
committerMartchus2023-07-20 23:11:51 +0200
commita6703a22ca31bfc087634e229633ad6926c78a98 (patch)
tree1e2932182cef948c8ca2f99c9e5b651e52129a4f /PKGBUILD
parent16b9ee7ca086c4b4299e2a43bc623e06f95e502b (diff)
downloadaur-a6703a22ca31bfc087634e229633ad6926c78a98.tar.gz
Update to 6.5.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f69dd0a272aa..e2d1dfa650dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# you also find the URL of a binary repository.
pkgname=mingw-w64-qt6-5compat-static
-_qtver=6.5.1
+_qtver=6.5.2
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -17,7 +17,7 @@ options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
groups=(mingw-w64-qt6)
_pkgfqn="qt5compat-everywhere-src-${_qtver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('ae992b295fefabef2445beb3a8ec31c40fa0fb2c01603eaf2acfdb4a0054fb83')
+sha256sums=('b9abe42ee2055c27a8e7579c7816069e91aae1f9b10649bf572db8ba96fa91c4')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
@@ -26,6 +26,7 @@ build() {
export PKG_CONFIG=/usr/bin/$_arch-pkg-config
$_arch-cmake-static -G Ninja -B build-$_arch -S $_pkgfqn \
-DCMAKE_INSTALL_PREFIX:PATH="/usr/$_arch/static" \
+ -DCMAKE_DISABLE_FIND_PACKAGE_harfbuzz=TRUE \
-DFEATURE_static_runtime=ON \
-DFEATURE_pkg_config=ON
cmake --build build-$_arch