summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2021-02-05 22:20:40 +0100
committerMartchus2021-02-05 22:20:40 +0100
commit39688011c99d628aa13ffdbe4a9f50ab16c94070 (patch)
treeb8b000bb6e4c283bb8020a65fcfbf69f67423072 /PKGBUILD
parent1833663bc8c9e320beb2f9af3c2ffe339cc9a60e (diff)
downloadaur-39688011c99d628aa13ffdbe4a9f50ab16c94070.tar.gz
Update to 6.0.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 16 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f0385cbedb88..b9ed941acb46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# you also find the URL of a binary repository.
pkgname=mingw-w64-qt6-declarative
-_qtver=6.0.0
+_qtver=6.0.1
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -17,11 +17,23 @@ optdepends=('qt6-declarative: development tools')
options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
groups=(mingw-w64-qt6)
_pkgfqn="qtdeclarative-everywhere-src-${_qtver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('8535fe31fa3e876b8f2d3954efcdca47b3813adf228c1640608fb9f4c7b2c1a6')
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
+ '0001-Exclude-qmltime-when-cross-compiling.patch')
+sha256sums=('6e234508d3d624bdeb90e67f09f95b7bb9bc712f60f82f64ddd99132eff5f610'
+ 'c252273963e8508483b1edd09463640fdaee4d4c123dc4f000940f9f237f4e54')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+prepare () {
+ cd $_pkgfqn
+
+ # apply patches; further descriptions can be found in patch files itself
+ for patch in "$srcdir/"*.patch; do
+ msg2 "Applying patch $patch"
+ patch -p1 -i "$patch"
+ done
+}
+
build() {
for _arch in ${_architectures}; do
export PKG_CONFIG=/usr/bin/$_arch-pkg-config
@@ -48,6 +60,7 @@ package() {
find "$pkgdir/usr/$_arch" -iname '*.exe' -exec $_arch-strip --strip-all {} \;
find "$pkgdir/usr/$_arch" -iname '*.dll' -exec $_arch-strip --strip-unneeded {} \;
find "$pkgdir/usr/$_arch" -iname '*.a' -exec $_arch-strip -g {} \;
+ [[ -d "$pkgdir/usr/$_arch/share/doc" ]] && rm -r "$pkgdir/usr/$_arch/share/doc"
done
install -d "$pkgdir"/usr/share/licenses