summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2023-07-20 23:11:55 +0200
committerMartchus2023-07-20 23:11:55 +0200
commitb6625830e2148b766a285546e9d709ba9111bcbc (patch)
treee2988f3ff9eb133dc8e37d5d41928b71085cfa0a /PKGBUILD
parentac081551e52915525b53806f8bb4a22a88bd94e2 (diff)
downloadaur-b6625830e2148b766a285546e9d709ba9111bcbc.tar.gz
Update to 6.5.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd04759806aa..2adebecde073 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# you also find the URL of a binary repository.
pkgname=mingw-w64-qt6-quicktimeline-static
-_qtver=6.5.1
+_qtver=6.5.2
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -17,7 +17,7 @@ options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
groups=(mingw-w64-qt6)
_pkgfqn="qtquicktimeline-everywhere-src-${_qtver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('1079dba276c51b9bbc9bfd90014005eb94339a6ce18a4f3fb1b6f4724f4ad551')
+sha256sums=('c945ae905dc1542967c7f9bea826022235bc179c2ed59142c029336c03f015ba')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
@@ -26,6 +26,7 @@ build() {
export PKG_CONFIG=/usr/bin/$_arch-pkg-config
$_arch-cmake-static -G Ninja -B build-$_arch -S $_pkgfqn \
-DCMAKE_INSTALL_PREFIX:PATH="/usr/$_arch/static" \
+ -DCMAKE_DISABLE_FIND_PACKAGE_harfbuzz=TRUE \
-DFEATURE_static_runtime=ON \
-DFEATURE_pkg_config=ON
cmake --build build-$_arch