summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2020-11-08 20:26:10 +0100
committerMartchus2020-11-08 20:26:10 +0100
commit6f1d328aa26dedb0696d03d824ac179bf1b48241 (patch)
treebd0a4f7bf473374149d8f32d02e59d707a3d912d /PKGBUILD
parenta250d8a60e68665df74241b9889ff08f563435ce (diff)
downloadaur-6f1d328aa26dedb0696d03d824ac179bf1b48241.tar.gz
Add static mingw-w64-qt6-* packages
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 14 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a6816b90d18f..e63644698870 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,11 +16,23 @@ makedepends=('mingw-w64-cmake' 'mingw-w64-vulkan-headers' 'mingw-w64-vulkan-icd-
options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
groups=(mingw-w64-qt6)
_pkgfqn="qttools-everywhere-src-${_qtver}"
-source=("https://download.qt.io/development_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('8409de28939c79dc3eb2d1bb8bac085f35f3dcc35df107633b474733aa33bba8')
+source=("https://download.qt.io/development_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
+ '0001-windeployqt-Fix-name-of-qt6CoreName-variable.patch')
+sha256sums=('8409de28939c79dc3eb2d1bb8bac085f35f3dcc35df107633b474733aa33bba8'
+ '03ed0cf3fb604d773cae1de19c862e65e8a44a8245db0bfba750557e541f5620')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+prepare () {
+ cd $_pkgfqn
+
+ # apply patches; further descriptions can be found in patch files itself
+ for patch in "$srcdir/"*.patch; do
+ msg2 "Applying patch $patch"
+ patch -p1 -i "$patch"
+ done
+}
+
build() {
for _arch in ${_architectures}; do
export PKG_CONFIG=/usr/bin/$_arch-pkg-config