summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2021-02-05 22:21:31 +0100
committerMartchus2021-02-05 22:21:31 +0100
commitec883ba127504994a90c36c79f1d24b03e4a3f5f (patch)
tree7a8c30834a8925aa5caea2052881d908bc2464a4 /PKGBUILD
parentc08d0ec2eb08ea45bd009ccf94489c22263b3a58 (diff)
downloadaur-ec883ba127504994a90c36c79f1d24b03e4a3f5f.tar.gz
Update to 6.0.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 4 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 78e9608112c1..6af6340d98e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# you also find the URL of a binary repository.
pkgname=mingw-w64-qt6-tools
-_qtver=6.0.0
+_qtver=6.0.1
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -16,23 +16,11 @@ makedepends=('mingw-w64-cmake' 'mingw-w64-vulkan-headers' 'mingw-w64-vulkan-icd-
options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
groups=(mingw-w64-qt6)
_pkgfqn="qttools-everywhere-src-${_qtver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
- '0001-Make-windeployqt-an-optional-feature.patch')
-sha256sums=('b6dc559db447bf394d09dfb238d5c09108f834139a183888179e855c6566bfae'
- 'f316cdb87dcc84d1fe9ebd262812118e35571aa0fadd3da6ac3b9f42af19b8bb')
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
+sha256sums=('dc354358f7d2ed56d17190f4ad7e3fc3ad88185be1eb74b9132b8b66185c349f')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
-prepare () {
- cd $_pkgfqn
-
- # apply patches; further descriptions can be found in patch files itself
- for patch in "$srcdir/"*.patch; do
- msg2 "Applying patch $patch"
- patch -p1 -i "$patch"
- done
-}
-
build() {
for _arch in ${_architectures}; do
export PKG_CONFIG=/usr/bin/$_arch-pkg-config
@@ -60,6 +48,7 @@ package() {
find "$pkgdir/usr/$_arch" -iname '*.exe' -exec $_arch-strip --strip-all {} \;
find "$pkgdir/usr/$_arch" -iname '*.dll' -exec $_arch-strip --strip-unneeded {} \;
find "$pkgdir/usr/$_arch" -iname '*.a' -exec $_arch-strip -g {} \;
+ [[ -d "$pkgdir/usr/$_arch/share/doc" ]] && rm -r "$pkgdir/usr/$_arch/share/doc"
done
install -d "$pkgdir"/usr/share/licenses