summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2021-06-10 15:43:11 +0200
committerMartchus2021-06-10 15:43:11 +0200
commit40ba855ca5e130fcb2e58c7d2e8c1025aa6c709a (patch)
tree64187d2125a3d3ed06cb0e1eb9a4db53c7b88e6e /PKGBUILD
parent97b26accde68e2d8bb249f489f8e9db7b72cfc1d (diff)
downloadaur-40ba855ca5e130fcb2e58c7d2e8c1025aa6c709a.tar.gz
Update to 6.1.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 15 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 69aa87289636..baa78c0399d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# you also find the URL of a binary repository.
pkgname=mingw-w64-qt6-tools-static
-_qtver=6.1.0
+_qtver=6.1.1
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -16,11 +16,23 @@ makedepends=('mingw-w64-cmake-static' 'mingw-w64-vulkan-headers' 'mingw-w64-vulk
options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
groups=(mingw-w64-qt6)
_pkgfqn="qttools-everywhere-src-${_qtver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('6263030c1120a30b0541d37b52dc0be0ea04bbb8d1695ec9648f0bd77e421f3e')
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
+ '0001-Enable-only-SQL-plugins-which-are-known-to-work.patch')
+sha256sums=('cba8d9a836e83b7a5e6d068239635b261f7ca4a059992b2b66cd546380091273'
+ '7254956e64929072ab0dae3aa14ad392eaceb070a7c02da75b3f3c770b1f7cfa')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+prepare () {
+ cd $_pkgfqn
+
+ # apply patches; further descriptions can be found in patch files itself
+ for patch in "$srcdir/"*.patch; do
+ msg2 "Applying patch $patch"
+ patch -p1 -i "$patch"
+ done
+}
+
build() {
for _arch in ${_architectures}; do
export PKG_CONFIG=/usr/bin/$_arch-pkg-config