summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2018-01-20 23:15:17 +0100
committerMartchus2018-01-20 23:15:17 +0100
commit41b2f068e1d645d9854f893ecde1ba361724d2d9 (patch)
tree97afef08498d149b8e1f8df107802847838fbbac /PKGBUILD
parent11acfb0a75af350ac06dfc86052a8b876a3de350 (diff)
downloadaur-41b2f068e1d645d9854f893ecde1ba361724d2d9.tar.gz
Update version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 17971cdef3d5..4a6ded547558 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_reponame=qtutilities
pkgname=mingw-w64-qtutilities
_name=${pkgname#mingw-w64-}
-pkgver=5.8.1
+pkgver=5.8.2
pkgrel=1
arch=('any')
pkgdesc='Common Qt related C++ classes and routines used by my applications such as dialogs, widgets and models (mingw-w64)'
@@ -16,7 +16,7 @@ makedepends=('mingw-w64-gcc' 'mingw-w64-cmake' 'mingw-w64-qt5-tools')
optdepends=("$_name-doc: API documentation")
url="https://github.com/Martchus/${_reponame}"
source=("${_name}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('f3e72a98aabb31a36fe1294be2e6c5fec66bdd26faf95386554d7e8981c43383')
+sha256sums=('a20cdd3e854c77bc25f9a05c079e5b81dc53d1eef3b8a6d913f3f14d8b6eabaa')
options=(!buildflags staticlibs !strip !emptydirs)
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_STATIC_LIBS ]] ||
@@ -31,7 +31,11 @@ build() {
export PREVENT_FORCING_SHARED_LIBS=ON
for _arch in ${_architectures}; do
mkdir -p "build-${_arch}" && pushd "build-${_arch}"
- ${_arch}-cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="/usr/${_arch}" ${_configurations} ../
+ ${_arch}-cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="/usr/${_arch}" \
+ -DBUILTIN_TRANSLATIONS:BOOL=ON \
+ ${_configurations} ../
make
popd
done