summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2020-12-02 02:08:44 +0100
committerMartchus2020-12-02 02:08:44 +0100
commitc80ec10d8a855c74b02889840e7d425a72adb2f8 (patch)
tree8b5d234c25887ab687ce6376c59f26be5ef0632b /PKGBUILD
parent35cb4e5d7d15873588f21f9896b58e44f1db16c9 (diff)
downloadaur-c80ec10d8a855c74b02889840e7d425a72adb2f8.tar.gz
Update version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1740c6f63e80..21f05b1da737 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_reponame=qtutilities
pkgname=mingw-w64-qtutilities
_name=${pkgname#mingw-w64-}
-pkgver=6.3.1
+pkgver=6.3.2
pkgrel=1
arch=('any')
pkgdesc='Common Qt related C++ classes and routines used by my applications such as dialogs, widgets and models (mingw-w64)'
@@ -17,7 +17,7 @@ checkdepends=('mingw-w64-wine')
makedepends=('mingw-w64-gcc' 'mingw-w64-cmake' 'mingw-w64-qt5-tools' 'ninja')
url="https://github.com/Martchus/${_reponame}"
source=("${_name}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('57c0614789a18830407bbdb0078a1d9651edd29c472eb6c941af9e273ef7460e')
+sha256sums=('c367a445f6d8e273787e733f8701ebea001f9dea1fb1e317580e976a48b42df1')
options=(!buildflags staticlibs !strip !emptydirs)
_architectures=('i686-w64-mingw32' 'x86_64-w64-mingw32')
@@ -70,7 +70,8 @@ check() {
msg2 "${_arch}-${_cfg}"
pushd "build-${_arch}-${_cfg}"
export WINEPATH="/usr/${_arch}/bin" WINEDEBUG=-all
- QT_QPA_PLATFORM=offscreen ninja check || test "$_cfg" = static
+ export QT_QPA_PLATFORM=offscreen
+ [[ $_cfg == shared ]] && ninja tests
popd
done
done