summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2019-03-27 15:42:28 +0100
committerMartchus2019-03-27 15:42:28 +0100
commit6032e4f282de2b030a0dcf98c54578320bd75d34 (patch)
tree3cfca6a172f12158473c26521276707d7235337a /PKGBUILD
parent29982e6514d74bbc25147ca2931176a66f77f770 (diff)
downloadaur-6032e4f282de2b030a0dcf98c54578320bd75d34.tar.gz
Update version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 74414af7f734..d626f07b233e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_reponame=reflective-rapidjson
pkgname=mingw-w64-reflective-rapidjson
_name=${pkgname#mingw-w64-}
-pkgver=0.0.6
+pkgver=0.0.7
pkgrel=1
arch=('any')
pkgdesc='Code generator for serializing/deserializing C++ objects to/from JSON using Clang and RapidJSON (mingw-w64)'
@@ -18,7 +18,7 @@ checkdepends=('mingw-w64-cppunit' 'mingw-w64-wine' 'mingw-w64-boost')
makedepends=('mingw-w64-gcc' 'mingw-w64-cmake')
url="https://github.com/Martchus/${_reponame}"
source=("${_name}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('4e0a30716d905840359c35edc2acf3933cbe9be2e81de80a28beb119c1163c53')
+sha256sums=('d10e21909b29f960a9dc5e8d925511597e35e2a8436b2732bc2e224acbd62b73')
options=(!buildflags staticlibs !strip !emptydirs)
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_STATIC_LIBS ]] || _configurations='-DENABLE_STATIC_LIBS:BOOL=ON'
@@ -34,6 +34,10 @@ build() {
-DNO_GENERATOR=ON \
${_configurations} \
../
+
+ # workaround issue https://gitlab.kitware.com/cmake/cmake/issues/19095
+ find -iname 'includes_CXX.rsp' -exec sed -i -e "s|-isystem /usr/$_arch/include ||" {} \;
+
make
popd
done