summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVaporeon2024-02-29 15:47:56 +1300
committerVaporeon2024-02-29 15:47:56 +1300
commitb13856b9689f0d41ce7c48e37b98fe2cf64ef192 (patch)
tree4403df1fb9a9cab1596a34fefde826f987990921 /PKGBUILD
parent6e4a9a6546a09678f742da6bbc75b8799eee4b8f (diff)
downloadaur-b13856b9689f0d41ce7c48e37b98fe2cf64ef192.tar.gz
Update to 2.30.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 3 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f2cf1733ad2..9f81bfaf4b49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mingw-w64-sdl2
-pkgver=2.28.5
+pkgver=2.30.0
pkgrel=1
pkgdesc='A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard (Version 2) (mingw-w64)'
license=('MIT')
@@ -10,14 +10,9 @@ _archs=('i686-w64-mingw32' 'x86_64-w64-mingw32')
depends=('mingw-w64-crt')
makedepends=('mingw-w64-configure')
source=("${url}/release/SDL2-${pkgver}.tar.gz")
-sha256sums=('332cb37d0be20cb9541739c61f79bae5a477427d79ae85e352089afdaf6666e4')
+sha256sums=('36e2e41557e0fa4a1519315c0f5958a87ccb27e25c51776beb6f1239526447b0')
options=(staticlibs '!strip' '!buildflags')
-prepare() {
- cd "${srcdir}/SDL2-${pkgver}"
- sed -i 's:IMPORTED_LOCATION "@libdir@/libSDL2\.so":IMPORTED_LOCATION "@bindir@/SDL2.dll" IMPORTED_IMPLIB "@libdir@/libSDL2.dll.a":' sdl2-config.cmake.in
-}
-
build() {
export MINGW_LDFLAGS="-s"
cd "${srcdir}/SDL2-${pkgver}"
@@ -41,7 +36,7 @@ package() {
find "${pkgdir}/usr/${_arch}/bin" -name "*.dll" -exec ${_arch}-strip --strip-unneeded {} \;
find "${pkgdir}/usr/${_arch}/lib" -name "*.a" -exec ${_arch}-strip -g {} \;
cp "${pkgdir}/usr/${_arch}/lib/libSDL2.a" "${pkgdir}/usr/${_arch}/lib/libSDL2-static.a"
- ln -s "/usr/${_arch}/bin/sdl2-config" "${pkgdir}/usr/bin/${_arch}-sdl2-config"
+ ln -s "/usr/${_arch}/bin/sdl2-config" "${pkgdir}/usr/bin/${_arch}-sdl2-config"
popd
done
}