summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorProkop Randacek2022-01-22 10:39:34 +0100
committerProkop Randacek2022-01-22 10:43:42 +0100
commitb90b87ac0e68969cb7d34c38b478b79f330f8133 (patch)
treecefcff9e381e896142580c8be5b583fe604ee048 /PKGBUILD
parent7d02deb51a618df73b5c4df1c0115c53236ae4e7 (diff)
downloadaur-b90b87ac0e68969cb7d34c38b478b79f330f8133.tar.gz
2021.4, small cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f182de71e143..beb29d3b06b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,26 @@
+# Maintainer: Prokop Randáček <prokop@randacek.dev>
pkgname=mingw-w64-spirv-tools
-pkgver=2021.3
+pkgver=2021.4
pkgrel=1
-pkgdesc="API and commands for processing SPIR-V modules (mingw-w64)"
+pkgdesc='API and commands for processing SPIR-V modules (mingw-w64)'
arch=('any')
-url="https://www.khronos.org/vulkan/"
-license=('custom')
+url='https://github.com/KhronosGroup/SPIRV-Tools'
+license=('Apache')
depends=('mingw-w64-crt')
-makedepends=('mingw-w64-cmake' 'mingw-w64-spirv-headers' 'python' 'git')
+makedepends=('mingw-w64-cmake' 'git' 'make' 'python')
options=('!strip' '!buildflags' 'staticlibs')
-source=("https://github.com/KhronosGroup/SPIRV-Tools/archive/v${pkgver}.tar.gz"
- "git+https://github.com/KhronosGroup/SPIRV-Headers.git")
-sha256sums=('b6b4194121ee8084c62b20f8d574c32f766e4e9237dfe60b0658b316d19c6b13'
- 'SKIP')
+source=("https://github.com/KhronosGroup/SPIRV-Tools/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('d68de260708dda785d109ff1ceeecde2d2ab71142fa5bf59061bb9f47dd3bb2c')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
cd SPIRV-Tools-${pkgver}
+ python3 utils/git-sync-deps
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-cmake \
-DCMAKE_BUILD_TYPE=Release \
- -DSPIRV-Headers_SOURCE_DIR="${srcdir}"/SPIRV-Headers \
-DSPIRV_SKIP_EXECUTABLES=ON \
-DSPIRV_SKIP_TESTS=ON \
-DSPIRV_WERROR=OFF \
@@ -39,3 +38,4 @@ package() {
${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.dll
done
}
+