summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2016-09-14 22:10:49 +0200
committerMartchus2016-09-14 22:10:49 +0200
commit22a7fb1c104200f8940ef431f428436c814d6d4e (patch)
treed85ef37c3e014afb4f70034f00965d11c62304c6 /PKGBUILD
parentdd893a458c0afded58d25093ff4976ba3659cd06 (diff)
downloadaur-22a7fb1c104200f8940ef431f428436c814d6d4e.tar.gz
Update version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dccafbabc82f..8ef9e494fdd0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,19 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
-# set the web view provider: either webkit, webengine or none
+# set the web view provider: either webkit, webengine, auto or none
_webview_provider=none
-# set the JavaScript provider: either script, qml or none
+# set the JavaScript provider: either script, qml, auto or none
_js_provider=script
-_name=tageditor
_reponame=tageditor
pkgname=mingw-w64-tageditor
-pkgver=1.4.0
+_name=${pkgname#mingw-w64-}
+pkgver=2.0.0
pkgrel=1
arch=('any')
-pkgdesc="A tag editor with Qt GUI and command-line interface supporting MP4/M4A/AAC (iTunes), ID3, Vorbis, Opus and Matroska (mingw-w64)."
+pkgdesc='A tag editor with Qt GUI and command-line interface supporting MP4/M4A/AAC (iTunes), ID3, Vorbis, Opus and Matroska'
license=('GPL')
depends=(mingw-w64-{crt,qtutilities,tagparser})
[[ $_webview_provider == none ]] && [[ $_js_provider == none ]] && depends+=('mingw-w64-qt5-base')
@@ -25,14 +25,13 @@ depends=(mingw-w64-{crt,qtutilities,tagparser})
[[ $_js_provider == qml ]] && depends+=('mingw-w64-qt5-declarative')
makedepends=('mingw-w64-gcc' 'mingw-w64-cmake' 'mingw-w64-qt5-tools' 'ffmpeg')
url="https://github.com/Martchus/${_reponame}"
-source=("tageditor-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('37281b85c633b2f91310c0747f6ae69a108961ee5de1fa5ad3ba27a1707359aa')
+source=("${_reponame}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
+sha256sums=('b3818112660b14b5e50c2b2f9521a1aaa1dafc12145e340fc5b210ee36056e41')
options=(!buildflags staticlibs !strip !emptydirs)
-_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
build() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
- # build utilities for each architecture
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-cmake \