summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2018-01-20 23:15:19 +0100
committerMartchus2018-01-20 23:15:19 +0100
commit2f4d46ccd048c6a18f3a0ae97caadeac9034d82c (patch)
tree92c745d0ffc574ea6919b0720b11ea3752f1f568 /PKGBUILD
parent4c558830e81eec2107a3085cbf76323bd262cc5d (diff)
downloadaur-2f4d46ccd048c6a18f3a0ae97caadeac9034d82c.tar.gz
Update version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 13ac98e40326..e2206c4c375c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,10 +9,13 @@ _webview_provider=none
# set the JavaScript provider: either script, qml, auto or none
_js_provider=script
+# whether the experimental JSON export is enabled: ON or OFF
+_json_export=ON
+
_reponame=tageditor
pkgname=mingw-w64-tageditor
_name=${pkgname#mingw-w64-}
-pkgver=2.3.0
+pkgver=2.3.1
pkgrel=1
arch=('any')
pkgdesc='A tag editor with Qt GUI and command-line interface supporting MP4/M4A/AAC (iTunes), ID3, Vorbis, Opus, FLAC and Matroska'
@@ -24,9 +27,10 @@ depends=('mingw-w64-crt' 'mingw-w64-qtutilities>=5.6.0' 'mingw-w64-tagparser>=6.
[[ $_js_provider == script ]] && depends+=('mingw-w64-qt5-script>=5.6')
[[ $_js_provider == qml ]] && depends+=('mingw-w64-qt5-declarative>=5.6')
makedepends=('mingw-w64-gcc' 'mingw-w64-cmake' 'mingw-w64-qt5-tools' 'ffmpeg')
+[[ $_json_export == ON ]] && makedepends+=('mingw-w64-reflective-rapidjson')
url="https://github.com/Martchus/${_reponame}"
source=("${_name}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('bff72b3df7c919e45d7d0113b5b6ba5f939282c98d15a11a5e8c5d14d9d33dde')
+sha256sums=('3d9204c7a7e5a06916a7f6b97fbb50a32282c762fd9a432106254ed0d9706d79')
options=(!buildflags staticlibs !strip !emptydirs)
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
@@ -39,6 +43,8 @@ build() {
-DCMAKE_INSTALL_PREFIX="/usr/${_arch}" \
-DWEBVIEW_PROVIDER="${_webview_provider}" \
-DJS_PROVIDER="${_js_provider}" \
+ -DENABLE_JSON_EXPORT="${_json_export}" \
+ -DREFLECTION_GENERATOR_EXECUTABLE:FILEPATH='/usr/bin/reflective_rapidjson_generator' \
../
make
popd