summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2016-04-26 22:05:30 +0200
committerMartchus2016-04-26 22:05:30 +0200
commit4da5e6e3a2a274590dc875b678abd2207aae8af0 (patch)
treee571c7115840dcbaa4747d9a73654f3142e10732 /PKGBUILD
parentf3e507f8d3cb1313e9ed3199789d95a36e0dd995 (diff)
downloadaur-4da5e6e3a2a274590dc875b678abd2207aae8af0.tar.gz
updated version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eed30ebcb2a1..4b92d97bf2c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,21 @@
# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
_name=tagparser
_reponame=tagparser
pkgname=mingw-w64-tagparser
-pkgver=4.0.1
+pkgver=5.0.0
pkgrel=1
arch=('any')
-pkgdesc="C++ library for reading and writing MP4 (iTunes), ID3, Vorbis and Matroska tags (mingw-w64)."
+pkgdesc="C++ library for reading and writing MP4/M4A/AAC (iTunes), ID3, Vorbis, Opus and Matroska tags (mingw-w64)."
license=('GPL')
depends=('mingw-w64-crt' 'mingw-w64-c++utilities' 'mingw-w64-zlib')
makedepends=('mingw-w64-gcc' 'mingw-w64-cmake')
url="https://github.com/Martchus/${_reponame}"
source=("tagparser-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('db5789f24262c4adfcf9c9fa3f237fab0abb3717065e674c2f1ada96bfe0ed95')
+sha256sums=('a622711f62f99e18aea15bfa3bfdd31dd200eac504b82a891a0a5b8d725dc7c6')
options=(!buildflags staticlibs !strip !emptydirs)
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -20,7 +24,7 @@ build() {
# build utilities for each architecture
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr/${_arch}" ../
+ ${_arch}-cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="/usr/${_arch}" ../
make
popd
done
@@ -30,7 +34,7 @@ package() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
for _arch in ${_architectures}; do
pushd build-${_arch}
- make install-mingw-w64-strip
+ make DESTDIR="${pkgdir}" install-mingw-w64-strip
popd
done
}