summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2019-05-20 14:53:49 +0200
committerMichel Zou2019-05-20 14:53:49 +0200
commitf31d3a2d6ea86b0e7b25d393198b5383e558d436 (patch)
treebe92f60de2d288d6231b9581f3e2deeb10074ff2 /PKGBUILD
downloadaur-f31d3a2d6ea86b0e7b25d393198b5383e558d436.tar.gz
3.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b6325dddff6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=mingw-w64-utf8cpp
+pkgver=3.1
+pkgrel=1
+pkgdesc="UTF-8 with C++ in a Portable Way (mingw-w64)"
+url='http://utfcpp.sourceforge.net'
+arch=('any')
+license=('Custom')
+depends=()
+makedepends=('mingw-w64-cmake')
+options=('!buildflags' 'staticlibs' '!strip')
+source=("https://github.com/nemtrif/utfcpp/archive/v${pkgver}.tar.gz")
+sha256sums=('ab531c3fd5d275150430bfaca01d7d15e017a188183be932322f2f651506b096')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+
+build() {
+ cd "utfcpp-${pkgver}"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ # CYGWIN=1 to trick the build system to install the cmake config in lib/cmake/utf8cpp instead
+ ${_arch}-cmake -DUTF8_TESTS=OFF -DCYGWIN=1 ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "$srcdir/utfcpp-${pkgver}/build-${_arch}"
+ make install DESTDIR="$pkgdir"
+ done
+}