summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick Northon2023-09-09 07:34:49 -0400
committerPatrick Northon2023-09-09 07:34:49 -0400
commit65d8327ac47e80792f26d0f33de2f08727c70392 (patch)
treea72aaf8fd9a527b30a48931bcf3f9aad544a4a97 /PKGBUILD
parent1192768d05ea33f51da20af7756320c927f65499 (diff)
downloadaur-65d8327ac47e80792f26d0f33de2f08727c70392.tar.gz
Add missing header file.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 93abb220cd7f..9fff30bc835f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _pkgname=vulkan-headers
pkgname=mingw-w64-${_pkgname}
_dirname=Vulkan-Headers
pkgver=1.3.264
-pkgrel=1
+pkgrel=2
pkgdesc='Vulkan header files (mingw-w64)'
arch=(any)
url='https://www.khronos.org/vulkan/'
@@ -12,8 +12,11 @@ license=('APACHE')
makedepends=(mingw-w64-cmake)
groups=('mingw-w64-vulkan-devel')
options=(!buildflags staticlibs !strip)
-source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/KhronosGroup/${_dirname}/archive/v${pkgver}.tar.gz")
-sha256sums=('e5d47599b971d8fe223b034019f7da736a97cdd6c3899b83a5d8873ff23e0e62')
+source=(
+ "${_pkgname}-${pkgver}.tar.gz::https://github.com/KhronosGroup/${_dirname}/archive/v${pkgver}.tar.gz"
+ 'vulkan_hpp_macros.hpp')
+sha256sums=('e5d47599b971d8fe223b034019f7da736a97cdd6c3899b83a5d8873ff23e0e62'
+ 'f04edce292c8a6971c058ce98015ceae7d1efc184213a468cb679293900e1fe3')
_srcdir="${_dirname}-${pkgver}"
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
@@ -28,5 +31,6 @@ build() {
package() {
for _arch in ${_architectures}; do
DESTDIR="${pkgdir}" cmake --install "build-${_arch}"
+ install -Dm644 "${srcdir}/vulkan_hpp_macros.hpp" "${pkgdir}/usr/${_arch}/include/vulkan/"
done
}