summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpingplug2023-11-27 12:25:47 +0800
committerpingplug2023-11-27 12:25:47 +0800
commit5afb7883ccd126069ef09b2f01095c5e0c6a9b79 (patch)
treec56730f64ca2823507e17569f5b080e5af5c20d9 /PKGBUILD
parent85271e7bc639e3e9dfdef4154c184cf74439e4ea (diff)
downloadaur-5afb7883ccd126069ef09b2f01095c5e0c6a9b79.tar.gz
updated to 3.2.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD83
1 files changed, 50 insertions, 33 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 939a8a5d495a..0bd6b6286055 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,59 +1,72 @@
-# Maintainer: Ivan Puntiy <ivan.puntiy-at-gmail>
+# Maintainer: pingplug < aur at pingplug dot me >
+# Contributor: Ivan Puntiy <ivan.puntiy-at-gmail>
# Contributor: Schala
pkgname=mingw-w64-wxmsw
-epoch=1
-pkgver=3.2.2.1
+pkgver=3.2.4
pkgrel=1
pkgdesc="Win32 implementation of wxWidgets API for GUI (mingw-w64)"
arch=(any)
url="https://wxwidgets.org"
license=("custom:wxWindows")
-makedepends=(mingw-w64-configure)
-depends=(mingw-w64-crt mingw-w64-expat mingw-w64-libpng mingw-w64-libjpeg-turbo mingw-w64-libtiff)
+makedepends=(mingw-w64-cmake)
+depends=(mingw-w64-crt
+ mingw-w64-expat
+ mingw-w64-libpng
+ mingw-w64-libjpeg-turbo
+ mingw-w64-libtiff)
options=(staticlibs !strip !buildflags)
conflicts=(mingw-w64-wxmsw2.9 mingw-w64-wxmsw-static)
provides=(mingw-w64-wxmsw2.9 mingw-w64-wxmsw-static)
source=("https://github.com/wxWidgets/wxWidgets/releases/download/v${pkgver}/wxWidgets-${pkgver}.tar.bz2")
-sha1sums=('d645cacbf2678cfc402ae163f2b0e0b05be5d239')
+sha256sums=('0640e1ab716db5af2ecb7389dbef6138d7679261fbff730d23845ba838ca133e')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+prepare() {
+ cd "${srcdir}/wxWidgets-${pkgver}"
+ # wxWidgets do not check MINGW and use MSVC_NAME
+ sed -i 's|AND NOT MSYS|AND NOT MSYS AND NOT MINGW|' build/cmake/functions.cmake
+}
build() {
- # --disable-option-checking -- prevents errors about `--enable-static` flag from `${arch}-configure`
local _build_flags="\
- --disable-option-checking \
- --with-msw \
- --with-opengl \
- --enable-unicode \
- --with-regex=builtin \
- --disable-precomp-headers \
- --enable-graphics_ctx \
- --enable-webview \
- --enable-mediactrl \
- --with-libpng=sys \
- --with-libxpm=builtin \
- --with-libjpeg=sys \
- --with-libtiff=sys"
-
- # Fix for current libuuid.a issues
- # see: https://github.com/Alexpux/MINGW-packages/issues/1761
- # looks like this was fixed, uncomment if needed
- # _build_flags="${_build_flags} LDFLAGS=-Wl,--allow-multiple-definition"
+ -DwxBUILD_PRECOMP=OFF \
+ -DwxBUILD_TOOLKIT=msw \
+ -DwxUSE_EXPAT=sys \
+ -DwxUSE_GRAPHICS_CONTEXT=ON \
+ -DwxUSE_LIBJPEG=sys \
+ -DwxUSE_LIBPNG=sys \
+ -DwxUSE_LIBTIFF=sys \
+ -DwxUSE_MEDIACTRL=ON \
+ -DwxUSE_OPENGL=ON \
+ -DwxUSE_REGEX=builtin \
+ -DwxUSE_UNICODE=ON \
+ -DwxUSE_WEBVIEW=ON \
+ -DwxUSE_ZLIB=sys"
cd "${srcdir}/wxWidgets-${pkgver}"
for _arch in ${_architectures}; do
# shared build
mkdir -p build-shared-${_arch} && pushd build-shared-${_arch}
- ${_arch}-configure ${_build_flags} --enable-monolithic ..
- make
+ ${_arch}-cmake .. \
+ -DBUILD_SHARED_LIBS:BOOL=ON \
+ -DwxBUILD_MONOLITHIC=ON \
+ ${_build_flags}
+ cmake --build .
popd
# static build
mkdir -p build-static-${_arch} && pushd build-static-${_arch}
- ${_arch}-configure ${_build_flags} --disable-shared ..
- make
+ ${_arch}-cmake .. \
+ -DBUILD_SHARED_LIBS:BOOL=OFF \
+ ${_build_flags}
+ cmake --build .
+ popd
+
+ # Run configure to generate the Makefile, cmake doesn't install translations
+ mkdir -p build-locale-${_arch} && pushd build-locale-${_arch}
+ ${_arch}-configure --disable-option-checking ..
popd
done
}
@@ -63,17 +76,21 @@ package() {
for _arch in ${_architectures}; do
for _build in shared static; do
cd "${srcdir}/wxWidgets-${pkgver}/build-${_build}-${_arch}"
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" cmake --install .
done
+ # Install translations
+ cd "${srcdir}/wxWidgets-${pkgver}/build-locale-${_arch}"
+ make DESTDIR="$pkgdir" locale_install
+
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
ln -s "/usr/${_arch}/lib/wx/config/${_arch}-msw-unicode-${pkgver%.*}" \
"$pkgdir/usr/bin/${_arch}-wx-config"
- # rm "${pkgdir}/usr/${_arch}/bin/"*.exe
- # rm "$pkgdir/usr/${_arch}/bin/wxrc-3.0"
- # rm -r "$pkgdir/usr/${_arch}/share"
+ install -Dm644 "${srcdir}/wxWidgets-${pkgver}/wxwin.m4" -t "$pkgdir"/usr/${_arch}/share/aclocal
done
+
+ install -Dm644 "${srcdir}/wxWidgets-${pkgver}/docs/licence.txt" "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}