summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick Northon2021-09-24 10:11:31 -0400
committerPatrick Northon2021-09-24 10:11:31 -0400
commit4d350ed49e129b3a96d241183ee07a4bca22af19 (patch)
tree6f70cd053109122433fff608397428273ce7726e /PKGBUILD
parentdd061dbeee16203440e5bcab45b6a6e5cc769c6c (diff)
downloadaur-4d350ed49e129b3a96d241183ee07a4bca22af19.tar.gz
Add proper striping and patch for mingw.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 19 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b62adc8597f3..1ef48ac1b61b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,36 @@
# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
pkgname=mingw-w64-xalan-c-icu
-provides=("mingw-w64-xalan-c")
-conflicts=("mingw-w64-xalan-c")
+provides=('mingw-w64-xalan-c')
+conflicts=('mingw-w64-xalan-c')
pkgver=1.12.0
-pkgrel=5
-_filever="1_12_0"
-pkgdesc="A XSLT processor for transforming XML documents (ICU) (mingw-w64)"
-arch=("any")
-url="https://xalan.apache.org/"
-license=("APACHE")
+pkgrel=6
+_filever='1_12_0'
+pkgdesc='A XSLT processor for transforming XML documents (ICU) (mingw-w64)'
+arch=('any')
+url='https://xalan.apache.org/'
+license=('APACHE')
makedepends=('mingw-w64-cmake' 'mingw-w64-wine' 'git')
depends=('mingw-w64-crt' 'mingw-w64-xerces-c-icu' 'mingw-w64-icu')
options=('!strip' '!buildflags' 'staticlibs')
source=("https://github.com/apache/xalan-c/archive/Xalan-C_${_filever}.tar.gz"
- "fix-cross-compile.patch")
+ 'fix-cross-compile.patch'
+ 'https://github.com/apache/xalan-c/pull/36.patch')
sha256sums=(
- "f3d4f23af7f7914259f2f5dbd9cc1450d3ebe0b8c8163fd50fcac4a39c63fccd"
- "67ab886be3737b39816ab4b7cead15077fcd4808f5d991747343d8485013642a")
+ 'f3d4f23af7f7914259f2f5dbd9cc1450d3ebe0b8c8163fd50fcac4a39c63fccd'
+ 'bffe4d394b877d7a36c08efd7563ce9ccde3621ae3851dc9c00ce065cd360050'
+ 'ed5a03ffecb0476aa02e90aba99f12d843bfd90748481d7b1ffc6d524bf4d952')
-_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
prepare() {
cd "xalan-c-Xalan-C_${_filever}"
- patch -uNp1 < "../fix-cross-compile.patch"
- sed -i -r "s/_MSC_VER/_WIN32/" "src/xalanc/XalanExe/XalanExe.cpp"
+ patch -uNp1 < '../fix-cross-compile.patch'
+ patch -uNp1 < '../36.patch'
}
build() {
- _flags=( -Wno-dev -DCMAKE_BUILD_TYPE=Release -DCMAKE_CXX_FLAGS_RELEASE="-O2 -DNDEBUG" -Dtranscoder=icu -Ddoxygen=OFF )
+ _flags=( -Wno-dev -DCMAKE_BUILD_TYPE=Release -DCMAKE_CXX_FLAGS_RELEASE='-O2 -DNDEBUG' -Dtranscoder=icu -Ddoxygen=OFF )
for _arch in ${_architectures}; do
${_arch}-cmake -S "xalan-c-Xalan-C_${_filever}" -B "build-${_arch}" "${_flags[@]}"
@@ -39,6 +41,8 @@ build() {
package() {
for _arch in ${_architectures}; do
DESTDIR="${pkgdir}" cmake --install "build-${_arch}"
+ ${_arch}-strip "$pkgdir"/usr/${_arch}/bin/*.exe
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
done
}