summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick Northon2020-06-07 14:33:57 -0400
committerPatrick Northon2020-06-07 14:33:57 -0400
commit8e2cb535f860604da390285863482235463dd4e2 (patch)
tree327c443a9da44a23c59c45feda7d665e14d6c9dc /PKGBUILD
downloadaur-8e2cb535f860604da390285863482235463dd4e2.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..471dc67ec70f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
+
+pkgname=mingw-w64-xalan-c-icu
+provides=("mingw-w64-xalan-c")
+conflicts=("mingw-w64-xalan-c")
+pkgver=1.12.0
+pkgrel=1
+_filever="1_12_0"
+pkgdesc="The Apache Xalan-C++ Project provides a library and a command line program to transform XML documents using a stylesheet that conforms to XSLT 1.0 standards. (ICU enabled)"
+arch=(any)
+url="https://xalan.apache.org/"
+license=("APACHE")
+makedepends=('mingw-w64-cmake' 'mingw-w64-wine' 'git')
+depends=('mingw-w64-crt' 'mingw-w64-xerces-c-icu' 'mingw-w64-icu')
+options=('!strip' '!buildflags' 'staticlibs')
+source=("https://github.com/apache/xalan-c/archive/Xalan-C_${_filever}.tar.gz"
+ "fix-cross-compile.patch")
+sha256sums=(
+ "f3d4f23af7f7914259f2f5dbd9cc1450d3ebe0b8c8163fd50fcac4a39c63fccd"
+ "67ab886be3737b39816ab4b7cead15077fcd4808f5d991747343d8485013642a")
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd "xalan-c-Xalan-C_${_filever}"
+ patch -uNp1 < "../fix-cross-compile.patch"
+ sed -i -r "s/_MSC_VER/_WIN32/" "src/xalanc/XalanExe/XalanExe.cpp"
+}
+
+build() {
+ for _arch in ${_architectures}; do
+ #${_arch}-cmake -S "xalan-c-Xalan-C_${_filever}" -B "build-${_arch}-static" -Dtranscoder=icu -DCMAKE_BUILD_TYPE=Release -Ddoxygen=OFF -DBUILD_SHARED_LIBS=FALSE
+ ${_arch}-cmake -S "xalan-c-Xalan-C_${_filever}" -B "build-${_arch}" -Dtranscoder=icu -DCMAKE_BUILD_TYPE=Release -Ddoxygen=OFF
+ make -C "build-${_arch}"
+ make -C "build-${_arch}"
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ #make DESTDIR="${pkgdir}" -C "build-${_arch}-static" install
+ make DESTDIR="${pkgdir}" -C "build-${_arch}" install
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}