summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick Northon2020-06-12 12:20:05 -0400
committerPatrick Northon2020-06-12 12:20:05 -0400
commit93cd4fe9564964719cc661c08aa1ec78bb023208 (patch)
tree9bb00597d9b5811be7f1346946683d7cb2714a6c /PKGBUILD
parentbe13b4ff66f6a299e43f70b10909140e6eeb9d56 (diff)
downloadaur-93cd4fe9564964719cc661c08aa1ec78bb023208.tar.gz
Correct compile flags.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aa1da0789400..bb209be83ec2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,10 @@ pkgname=mingw-w64-xalan-c-icu
provides=("mingw-w64-xalan-c")
conflicts=("mingw-w64-xalan-c")
pkgver=1.12.0
-pkgrel=2
+pkgrel=3
_filever="1_12_0"
pkgdesc="The Apache Xalan-C++ Project provides a library and a command line program to transform XML documents using a stylesheet that conforms to XSLT 1.0 standards. (ICU enabled)"
-arch=(any)
+arch=("any")
url="https://xalan.apache.org/"
license=("APACHE")
makedepends=('mingw-w64-cmake' 'mingw-w64-wine' 'git')
@@ -28,10 +28,12 @@ prepare() {
}
build() {
+ _flags=( -Wno-dev -DCMAKE_BUILD_TYPE=Release -DCMAKE_CXX_FLAGS_RELEASE="-O2 -DNDEBUG" -Dtranscoder=icu -Ddoxygen=OFF )
+
for _arch in ${_architectures}; do
- ${_arch}-cmake -S "xalan-c-Xalan-C_${_filever}" -B "build-${_arch}-static" -Dtranscoder=icu -DCMAKE_BUILD_TYPE=Release -Ddoxygen=OFF -DBUILD_SHARED_LIBS=FALSE
+ ${_arch}-cmake -S "xalan-c-Xalan-C_${_filever}" -B "build-${_arch}-static" "${_flags[@]}" -DBUILD_SHARED_LIBS=FALSE
make -C "build-${_arch}-static"
- ${_arch}-cmake -S "xalan-c-Xalan-C_${_filever}" -B "build-${_arch}" -Dtranscoder=icu -DCMAKE_BUILD_TYPE=Release -Ddoxygen=OFF
+ ${_arch}-cmake -S "xalan-c-Xalan-C_${_filever}" -B "build-${_arch}" "${_flags[@]}"
make -C "build-${_arch}"
done
}