summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJens Staal2015-08-24 08:54:34 +0200
committerJens Staal2015-08-24 08:54:34 +0200
commit88b7a43bfdcb3cde6acc9a4581a9fe927e6693b3 (patch)
tree6bf090112a2f6923a665f0f1f1e55376d625e760 /PKGBUILD
downloadaur-88b7a43bfdcb3cde6acc9a4581a9fe927e6693b3.tar.gz
xcb-proto, dependency of xcb
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3fb4f50e379f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer Jens Staal <staal1978@gmial.com>
+# adopted from official xcb-proto package:
+# $Id$
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+pkgname=mingw-w64-xcb-proto
+pkgver=1.11
+pkgrel=1
+pkgdesc="XML-XCB protocol descriptions (mingw-w64)"
+arch=(any)
+url="http://xcb.freedesktop.org/"
+license=('custom')
+makedepends=('python' 'libxml2')
+source=($url/dist/xcb-proto-$pkgver.tar.bz2)
+sha256sums=('b4aceee6502a0ce45fc39b33c541a2df4715d00b72e660ebe8c5bb444771e32e')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd xcb-proto-$pkgver
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure
+ make
+ popd
+ done
+}
+
+package() {
+ cd xcb-proto-$pkgver
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/xcb-proto-${pkgver}/build-${_arch}"
+ make DESTDIR="$pkgdir" install
+ done
+}