summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkfg2021-12-09 18:09:10 +0100
committerkfg2022-01-23 20:37:24 +0100
commitf36ba17e9644b56e474643aac13bff8e07e8e88b (patch)
tree9fc3e8b2a36327e23cefb8531d3b206ebfdf141f /PKGBUILD
parente126b4d8480912b6b43a4951e7ec25f005dc82e3 (diff)
downloadaur-f36ba17e9644b56e474643aac13bff8e07e8e88b.tar.gz
upgpkg: mingw-w64-xxhash 0.8.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d31c77aaa6b0..0732719c16a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Konstantin Gizdov <arch@kge.com>
pkgname=mingw-w64-xxhash
-pkgver=0.8.0
-pkgrel=2
+pkgver=0.8.1
+pkgrel=1
pkgdesc='Extremely fast non-cryptographic hash algorithm (mingw-w64)'
arch=('any')
url=https://cyan4973.github.io/xxHash/
@@ -16,11 +16,11 @@ license=(
depends=('mingw-w64-crt')
options=(!strip !buildflags staticlibs)
makedepends=('mingw-w64-gcc' 'mingw-w64-make' 'git')
-_tag=94e5f23e736f2bb67ebdf90727353e65344f9fc0
+_tag=35b0373c697b5f160d3db26b1cbb45a0d5ba788c
source=(git+https://github.com/Cyan4973/xxHash.git#tag=${_tag}
mingw-Makefile.patch)
-sha256sums=('SKIP'
- 'c40bd594773be56a44f709405d3623d8f0c0d15d3bb78e891577d33ca3d82c56')
+b2sums=('SKIP'
+ 'dae60c9356e0f27575ef29da73c3c000ce48baeb4ec3dfab57264fe39559374128316729b4db933a97c0fe35da8024c5879c70ba6ecab0a36114d1c80552c98d')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
pkgver() {
@@ -45,6 +45,7 @@ package() {
for _arch in ${_architectures}; do
cd "${srcdir}"/build-${_arch}
${_arch}-make PREFIX=/usr/${_arch} DESTDIR="${pkgdir}" install
+ mv "${pkgdir}"/usr/${_arch}/bin/libxxhash.dll.a "${pkgdir}"/usr/${_arch}/lib/libxxhash.dll.a
install -Dm 644 LICENSE -t "${pkgdir}"/usr/${_arch}/share/licenses/xxhash
done
}