summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpingplug2018-05-02 19:16:51 +0800
committerpingplug2018-05-02 19:16:51 +0800
commit2a61af487f7b01e6fa958f48f3846c6f7a7de0ad (patch)
tree101d1f919b2f4e4cee9d02dae2644e65b4b94eff /PKGBUILD
parent4ad199cb9bd0248bac5a21f63bc2c51089d61ac8 (diff)
downloadaur-2a61af487f7b01e6fa958f48f3846c6f7a7de0ad.tar.gz
Updated to 5.2.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 19 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e2bc5343102..2a51f11bacba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,22 @@
# Contributor: Philip A Reimer <antreimer@gmail.com>
# Contributor: Schala Zeal <schalaalexiazeal@gmail.com>
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
pkgname=mingw-w64-xz
-pkgver=5.2.3
+pkgver=5.2.4
pkgrel=1
pkgdesc="Library and command line tools for XZ and LZMA compressed files (mingw-w64)"
arch=('any')
-url="http://tukaani.org/xz"
-license=("custom" "GPL" "LGPL")
-makedepends=("mingw-w64-configure")
-depends=("mingw-w64-crt")
-options=(staticlibs !strip !buildflags)
-source=("$url/xz-${pkgver}.tar.gz")
-sha256sums=('71928b357d0a09a12a4b4c5fafca8c31c19b0e7d3b8ebb19622e96f26dbf28cb')
-
-
-_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+url="https://tukaani.org/xz"
+license=('custom' 'GPL' 'LGPL')
+depends=('mingw-w64-crt')
+makedepends=('mingw-w64-configure')
+options=('!strip' 'staticlibs' '!buildflags')
+source=("${url}/xz-${pkgver}.tar.gz"{,.sig})
+sha256sums=('b512f3b726d3b37b6dc4c8570e137b9311e7552e8ccbab4d39d47ce5f4177145'
+ 'SKIP')
+validpgpkeys=('3690C240CE51B4670D30AD1C38EE757D69184620') # Lasse Collin <lasse.collin@tukaani.org>
build() {
cd "${srcdir}/xz-${pkgver}"
@@ -31,12 +32,13 @@ build() {
package() {
for _arch in ${_architectures}; do
cd "${srcdir}/xz-${pkgver}/build-${_arch}"
- make DESTDIR="$pkgdir" install
- find "$pkgdir/usr/${_arch}" -name '*.exe' | xargs -rtl1 rm
- find "$pkgdir/usr/${_arch}" -name '*.dll' | xargs -rtl1 ${_arch}-strip -x
- find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs -rtl1 ${_arch}-strip -g
- rm "$pkgdir/usr/${_arch}/bin/"{lz{cmp,diff,egrep,fgrep,grep,less,more},xz{cmp,diff,egrep,fgrep,grep,less,more}}
- rm -r "$pkgdir/usr/${_arch}/share"
+ make DESTDIR="${pkgdir}" install
+ find "${pkgdir}/usr/${_arch}" -name '*.exe' | xargs -rtl1 rm
+ find "${pkgdir}/usr/${_arch}" -name '*.dll' | xargs -rtl1 ${_arch}-strip -x
+ find "${pkgdir}/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs -rtl1 ${_arch}-strip -g
+ rm "${pkgdir}/usr/${_arch}/bin/"{lz{cmp,diff,egrep,fgrep,grep,less,more},xz{cmp,diff,egrep,fgrep,grep,less,more}}
+ rm -r "${pkgdir}/usr/${_arch}/share"
done
}
+# vim:set ts=2 sw=2 et: