summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTor Vic2024-01-05 13:37:35 +0100
committerTor Vic2024-01-05 13:38:22 +0100
commitd1e11c0fe9d1533dad7b5af96a177b5a616660ab (patch)
tree0a85f3e0cf0a4b36ea32607b37290da4cebb6bdb /PKGBUILD
parentbb9d72bbc4b2c577faf4ea5de3384bc1bfd41900 (diff)
downloadaur-d1e11c0fe9d1533dad7b5af96a177b5a616660ab.tar.gz
move to own repository, set version to 2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 03b42c0caa5c..8f5107cfd231 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Tor Vic <torvic9 AT mailbox DOT org>
pkgname='mini-benchmarker'
-pkgver=0.9.r142.g953a1b9
+_ver=2.0
+pkgver=2.0.r2.gcbebebd
pkgrel=1
pkgdesc='A simple benchmarking script using stress-ng, perf, blender etc.'
url="https://gitlab.com/torvic9/bash-scripts/-/tree/master/mini-benchmarker"
@@ -10,15 +11,15 @@ licence=('GPL3')
depends=('gcc' 'make' 'cmake' 'time' 'perf' 'unzip'
'nasm' 'inxi' 'argon2' 'wget' 'x265' 'xz' 'zstd'
'zlib' 'libdrm' 'git' 'python' 'primesieve')
-source=(git+https://gitlab.com/torvic9/bash-scripts.git)
+source=(git+https://gitlab.com/torvic9/mini-benchmarker.git)
sha512sums=('SKIP')
pkgver() {
- cd bash-scripts/$pkgname
- git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd $pkgname
+ echo "${_ver}.r$(git rev-list HEAD --count).g$(git rev-list HEAD -1 --abbrev-commit)"
}
package() {
- cd bash-scripts/$pkgname
+ cd $pkgname
install -Dm755 $pkgname.sh "$pkgdir/usr/bin/$pkgname.sh"
}