summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRobert Zhou2017-11-12 21:54:43 -0800
committerMeep Zhou2017-11-12 22:11:56 -0800
commitcf659f93467cd50a33f06cc0ab0e7914e7a136c3 (patch)
tree81b8b11559fb74aa9bd0030023678cfd9250803d /PKGBUILD
parent645fc4d2117e9946f50478e8a1ffbc05ef19b586 (diff)
downloadaur-cf659f93467cd50a33f06cc0ab0e7914e7a136c3.tar.gz
Update 2.3.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 341bc6460cd8..31572180dc15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,25 @@
# Maintainer: meepzh <meep.aur@meepzh.com>
pkgname=minify
-pkgver=2.1.5
+pkgver=2.3.1
pkgrel=1
-pkgdesc="Minify CLI for HTML, CSS, JS, JSON, SVG and XML"
+pkgdesc="Minifier CLI for HTML, CSS, JS, JSON, SVG and XML"
arch=('x86_64' 'i686')
url="https://github.com/tdewolff/minify"
-license=('custom')
+license=('MIT')
+depends=('glibc')
if [ "$CARCH" = "i686" ]; then
_PKGARCH=386
else
_PKGARCH=amd64
fi
-source_x86_64=("https://bin.equinox.io/c/dhgbqpS8Bvy/minify-stable-linux-amd64.tgz")
-source_i686=("https://bin.equinox.io/c/dhgbqpS8Bvy/minify-stable-linux-386.tgz")
-md5sums_x86_64=('be4cf443c2778e2c81badfe94c5af46f')
-md5sums_i686=('08354a1fbc845a8c81c7886e2d6b3163')
+source_x86_64=("https://github.com/tdewolff/minify/releases/download/v2.3.1/minify_2.3.1_linux_amd64.tar.gz")
+source_i686=("https://github.com/tdewolff/minify/releases/download/v2.3.1/minify_2.3.1_linux_386.tar.gz")
+sha256sums_x86_64=('79dacbac822de54cb25568abf5e79f6f97c6b0e82aba199144d3c8b49f04ea30')
+sha256sums_i686=('eb62a7533d1a72ecbaf278e9a138ae6fbae901aa7c1c5918b04fbb604a142d45')
package() {
- install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m644 "LICENSE.md" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
+