summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoshua Merrell2016-03-31 00:58:36 -0700
committerJoshua Merrell2016-03-31 00:58:36 -0700
commit99b5ce0e38c12c651df48e629f4b3a676d56840c (patch)
tree9dd65aebf228dc56474d373a5002a5cbd3b39c2b /PKGBUILD
downloadaur-99b5ce0e38c12c651df48e629f4b3a676d56840c.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..901a13173855
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Joshua Merrell <joshuamerrell@gmail.com>
+pkgname=minisphere
+pkgver=3.0.1
+pkgrel=1
+pkgdesc="A fast, lightweight implementation of the Sphere game engine"
+arch=('i686' 'x86_64')
+url="https://github.com/fatcerberus/minisphere"
+license=('BSD')
+depends=('allegro' 'libmng')
+source=(https://github.com/fatcerberus/$pkgname/archive/v$pkgver.tar.gz)
+sha256sums=('aa76dee1e56fc3d84d62c8edb8d64afc0c71f003a45a257e5611ec9a074aa840')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}