summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2020-12-09 18:59:38 +0100
committerFabioLolix2020-12-09 18:59:38 +0100
commit8d71ce7b1541dfe4a0e5408a28e7c551a9d9f58d (patch)
tree6a946e7323e6ab18b2a183e07e14d058250663a6 /PKGBUILD
parent2d707a7dc70521fab14d941cd2b93725e8fa6b64 (diff)
downloadaur-8d71ce7b1541dfe4a0e5408a28e7c551a9d9f58d.tar.gz
v3.6.7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD57
1 files changed, 11 insertions, 46 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 92bf48d3f170..d61875f05652 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,55 +1,20 @@
# Maintainer : dreieck
-_pkgname=minitube
-pkgname="${_pkgname}-bin"
-pkgver=3.3
+pkgname=minitube-bin
+pkgver=3.6.7
pkgrel=1
-pkgdesc="A native YouTube client in Qt. Watch YouTube videos without Flash Player. Prebuilt binary with included Google API key."
-arch=('x86_64')
-url='https://flavio.tordini.org/minitube'
-license=('GPL3')
-install=minitube.install
-depends=(
- 'mpv'
- 'qt5-declarative'
- 'qt5-x11extras'
- 'hicolor-icon-theme'
-)
-makedepends=(
- 'archlinux-xdg-menu'
- 'dpkg'
-)
-provides=(
- "${_pkgname}=${pkgver}"
- "${_pkgname}-google-api-key"
-)
-conflicts=(
- "${_pkgname}"
-)
-source=(
- "${_pkgname}.deb::http://flavio.tordini.org/files/${_pkgname}/${_pkgname}.deb"
- "${install}"
-)
-sha256sums=(
- 'f517018cdbc006412c988ae49a07f3fde0916521fa2d6ae6c1acee0bb8601a24' # minitube.deb
- 'c7f4dd1ce7968635a0dbc44908a94e817e8ed6ab12d9443866ad28781038a25b' # minitube.install
-)
-noextract=(
- # "${_pkgname}.deb"
-)
-
-pkgver() {
- _ver="$(bsdtar -x -f "${srcdir}/control.tar.xz" -O control | grep -E '^Version:[[:space:]]+' | awk '{print $2}')"
- if [ -z ${_ver} ]; then
- echo "Error in 'pkgver()': Could not determine version." > /dev/stderr
- return 1
- fi
- echo "${_ver}"
-}
+pkgdesc="Native YouTube client in Qt, watch YouTube videos without Flash Player. Prebuilt binary with included Google API key."
+arch=(x86_64)
+url="https://flavio.tordini.org/minitube"
+license=(GPL3)
+depends=(mpv qt5-declarative qt5-x11extras)
+provides=(minitube)
+conflicts=(minitube)
+source_x86_64=("${pkgname}-x64-$(date +%F-%H-%M).deb::http://flavio.tordini.org/files/minitube/minitube.deb")
+sha256sums_x86_64=('8cebcd5f270411adb3746937971de10eff1bf215da200d750fa84695a2c68e57')
package() {
cd "${pkgdir}"
bsdtar -x -v -f "${srcdir}/data.tar.xz"
- # dpkg-deb -X "${srcdir}/${_pkgname}.deb" "${pkgdir}"
}