summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortheRealCarneiro2021-05-03 17:09:48 -0300
committertheRealCarneiro2021-05-03 17:09:48 -0300
commitc27d6504e5bfecfff66a798e89e105f9afcfaab2 (patch)
tree42cb105eeade6db2df48462df3837831ecc1730c /PKGBUILD
parentee25a28c48f914234b58b56586b70d5d2968a423 (diff)
downloadaur-minlau-git.tar.gz
added pkgver() function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index de23c65a8d1c..8ddd19b39ef7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Carneiro <gabriel dot chaves dot carneiro at gmail dot com>
pkgname=minlau-git
_pkgname=minlau
-pkgver=1.5
-pkgrel=2
+pkgver=1.5.r0.82ff767
+pkgrel=1
pkgdesc="A minimalist game launcher for wine"
url="https://github.com/theRealCarneiro/minlau"
arch=('i686' 'x86_64')
@@ -15,6 +15,11 @@ optdepends=('gamemode: optimizations to run games smoother'
source=(${_pkgname}::git+${url}.git)
md5sums=('SKIP')
+pkgver(){
+ cd $_pkgname
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
package() {
cd $_pkgname
DESTDIR=$pkgdir PREFIX=/usr ./setup.sh install