summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2021-03-06 12:50:26 +0100
committerhaawda2021-03-06 12:50:26 +0100
commitd1d0fff41ef07d6fb57f11b2155dedbe33882c05 (patch)
treec077b2521fb372c50194ed997b12c191966fda5f /PKGBUILD
parent1750b3edd5a4c9019358d2e591cc27dbbc04afbd (diff)
downloadaur-minlog-git.tar.gz
prefer guile over chez scheme for building
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9ed988c35c04..5632441d5300 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
pkgname=minlog-git
-pkgver=195.ff5c8ef
+pkgver=r610.4a9a1e4
pkgrel=2
pkgdesc="Interactive proof system based on first order natural deduction calculus."
arch=('any')
@@ -10,14 +11,19 @@ license=('GPL')
# in that order. I build with guile, because it is a dep of make and anyone has it
depends=('bash')
makedepends=('texlive-core' 'git')
-options=(!makeflags)
-
-source=("git+http://www.mathematik.uni-muenchen.de/~minlogit/git/minlog.git")
-md5sums=('SKIP')
+options=('!makeflags')
+source=("git+http://www.mathematik.uni-muenchen.de/~minlogit/git/minlog.git" prefer_guile.patch)
+md5sums=('SKIP'
+ '3066aa2dccf688b26d1c70ae8ebc3a7d')
pkgver() {
- cd ${pkgname%-git}
-printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd ${pkgname%-git}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${pkgname%-git}
+ git apply "$srcdir"/prefer_guile.patch
}
build() {