summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStefan Husmann2015-06-20 07:53:13 +0200
committerStefan Husmann2015-06-20 07:53:13 +0200
commit00e864787dfda9bf850c1c3acacc728e5b9d3022 (patch)
treec6066ed7ac03cb02699d8f97ffd4a0915e994c6a /PKGBUILD
downloadaur-00e864787dfda9bf850c1c3acacc728e5b9d3022.tar.gz
Update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e13bf3cabc4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+pkgname=minlog-git
+pkgver=171.f281021
+pkgrel=1
+pkgdesc="Interactive proof system based on first order natural deduction calculus."
+arch=('any')
+url="http://www.mathematik.uni-muenchen.de/~logik/minlog/index.php"
+license=('GPL')
+#you need a scheme, make searches for petite chez scheme, mzscheme or guile,
+# in that order. I build with guile, because it is a dep of make and anyone has it
+depends=('bash')
+makedepends=('texlive-core' 'git')
+source=("git+http://www.mathematik.uni-muenchen.de/~minlogit/git/minlog.git")
+md5sums=('SKIP')
+_gitname="minlog"
+
+pkgver() {
+ cd "$srcdir"/"$_gitname"
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ make DESTDIR=usr
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ make install DESTDIR="$pkgdir/usr"
+}